Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42
Like Tree47Likes

Thread: genesis style problems

  1. #1
    Senior Member
    Join Date
    Jan 2013
    Location
    Sydney
    Posts
    154

    genesis style problems

    Hey everyone,

    I got a [edit:i'd incorrectly identified it!] AGA-T unit today, which as far as i can tell is a DID style atomizer. I haven't had much luck so far. I've oxidised my wick and got the coils wrapped nicely, but no matter what I do only the top coil where it is close to the positive terminal glows. I can move things round as much as I like and no difference. I've made three wicks and gone through a heap of kanthal with no difference. different number of coils, different tightness, everything I can think of.
    The one time I seemed to have it working was with about 7-8 wraps and it didn't really glow at all, just heated, and a faint glow in the middle of the coil if I had it on long enough, I put some juice in it and the hit was absolutely choking on 3v. Like it was way to hot or not atomized properly or something.

    Anyway, I'm posting because I'm having trouble finding information that is useful. Most videos and posts talk about moving the coils to get them glowing evenly, but surely there must be something else I am doing wrong if only the top coil will glow no matter what I do. I'm rather confused. When I made a coil for my phoenix style atty I got a beautiful even glow without too much trouble. So if anyone can make a suggestion or point me at a good thread I would be very appreciative!

    Cheers,
    Nero

    Edit: sorry, 400#mesh and 32g kanthal being used
    Last edited by nero82; 28-03-13 at 07:58 PM.

  2. #2
    AVF Regular
    Join Date
    Nov 2012
    Location
    NT
    Posts
    3,687
    Wish I could help you mate, but my Genesis stuffs in the mail ( you got ahead of me lol) the VM zombie is a

    AGA-T Genesis Rebuildable Atomizer (Electronic Cigarette) - YouTube

    Someone with Genesis experience will help you out,,,
    nero82 likes this.
    Vaporista
    Noob for life


    Last Analog


    12-12-12 at Midnight

    "If it was easy, all the cool kids would be doing it",

  3. #3
    Senior Member
    Join Date
    Nov 2011
    Location
    Australia
    Posts
    4,055
    mathsguy and RichoVonBlack like this.

  4. #4
    Senior Member
    Join Date
    Jan 2013
    Location
    Sydney
    Posts
    154
    Oh so it is, thanks Richo

  5. #5
    AVF Regular
    Join Date
    Nov 2012
    Location
    NT
    Posts
    3,687
    Quote Originally Posted by <---cop View Post
    Cheers for that Cop, I'll use him for reference when I get my stuff
    Vaporista
    Noob for life


    Last Analog


    12-12-12 at Midnight

    "If it was easy, all the cool kids would be doing it",

  6. #6
    Senior Member
    Join Date
    Mar 2012
    Posts
    1,570
    Quote Originally Posted by nero82 View Post
    I've oxidised my wick and got the coils wrapped nicely, but no matter what I do only the top coil where it is close to the positive terminal glows.

    Edit: sorry, 400#mesh and 32g kanthal being used
    Hey Nero - that’s shorting to the wick.

    You might have:

    - not enough oxidising - or it got knocked off assembling
    - wrapped the wire too tightly

    Make sure your wick doesn’t touch the bottom of the tank, and is not too tight in the hole - I find wrapping the bit in the hole with some tally-hio to insulate helps.

    There are good threads on here and gujillions elsewhere - the best one is the one that makes you not throw the atty at the next person to come into the room! (OK you have a vid now)

    If you have the option, thicker wire and mesh is more forgiving.

    Make sure when you tighten the +ve terminal you are not further tightening the coil.

    Make sure you have some nice juice in a functioning carto/w’ever so you don’t get nic rage complicating your endeavours

    Use ‘The Force'

    Good luck.
    bart, Mushman, Bullos and 1 others like this.

  7. #7
    Senior Member
    Join Date
    Nov 2012
    Location
    Brisbane
    Posts
    2,877
    Quote Originally Posted by mathsguy View Post
    Hey Nero - that’s shorting to the wick.

    You might have:

    - not enough oxidising - or it got knocked off assembling
    - wrapped the wire too tightly

    Make sure your wick doesn’t touch the bottom of the tank, and is not too tight in the hole - I find wrapping the bit in the hole with some tally-hio to insulate helps.

    There are good threads on here and gujillions elsewhere - the best one is the one that makes you not throw the atty at the next person to come into the room! (OK you have a vid now)

    If you have the option, thicker wire and mesh is more forgiving.

    Make sure when you tighten the +ve terminal you are not further tightening the coil.

    Make sure you have some nice juice in a functioning carto/w’ever so you don’t get nic rage complicating your endeavours

    Use ‘The Force'

    Good luck.
    i wonder how we can tighten both terminals without affecting the coil tension. if you wrap it clock wise, it will tighten it, if you wrap it the other way, you will loosen it

  8. #8
    Senior Member
    Join Date
    Jan 2013
    Location
    Sydney
    Posts
    154
    Thanks Mathsguy,
    I suppose I'll try doing some more oxidising. I swear i flamed the bejesus out of it, but I will try again!

    Thats a great video cop, but I can't even get it to that stage, so it must be shorting I suppose.

    I know there are heaps of threads, but so many of the ones on SS wicks have blown out to hundreds of pages and I can't read through them all trying to find what is relevant to me!

    I'll see how some more oxidising helps
    mathsguy likes this.

  9. #9
    Senior Member
    Join Date
    Mar 2012
    Posts
    1,570
    Quote Originally Posted by silverx View Post
    i wonder how we can tighten both terminals without affecting the coil tension. if you wrap it clock wise, it will tighten it, if you wrap it the other way, you will loosen it
    If you use the drill method, it’s not an issue - otherwise got the ‘loosen’ option and make it a bit tighter than you need before screwing.

    Thicker wire helps too as you kink it around the post which tends to stop it a bit.
    Mushman likes this.

  10. #10
    Senior Member
    Join Date
    Nov 2012
    Location
    Brisbane
    Posts
    2,877
    Quote Originally Posted by nero82 View Post
    Thanks Mathsguy,
    I suppose I'll try doing some more oxidising. I swear i flamed the bejesus out of it, but I will try again!

    Thats a great video cop, but I can't even get it to that stage, so it must be shorting I suppose.

    I know there are heaps of threads, but so many of the ones on SS wicks have blown out to hundreds of pages and I can't read through them all trying to find what is relevant to me!

    I'll see how some more oxidising helps
    i found burning juice on it helps more than flaming bejesus out of it, matter of fact i only oxidised my wick last night once before rolling it, then burn juice like 10+ times and i dont see resistance drop. been vaping it all day today
    Mushman and mathsguy like this.

 

 
Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:15 PM.