Page 1 of 3 123 LastLast
Results 1 to 10 of 21
Like Tree2Likes

Thread: VAMO V2 thread problems

  1. #1
    AVF Newbie | Be nice to me
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    99

    VAMO V2 problems

    Hi All

    I got a VAMO V2 a couple of weeks ago and been using with 18650s, and opening it by the middle of the tube.
    I just got some 18350s on the mail, and now I have to use the end cap where the threads seem to fail.
    Anyone had this problem?

    EDIT: I also have another problem where the vamo takes more than 5 clicks to turn on, seems to be random. sometimes 6 clicks, 10 or when i get lucky 5!
    Last edited by casual; 13-04-13 at 11:45 AM.

  2. #2
    Senior Member
    Join Date
    Mar 2013
    Location
    Queensland
    Posts
    1,160
    Not had the problem. You can still use the 18350s and load them from the middle if you stack them. How do you mean fail? is the cap spinning or does it pop off or something?

  3. #3
    AVF Newbie | Be nice to me
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    99
    it doesn't screw well, goes only half way, I dont want to put more pressure into it, to avoid crossthreading.

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Have you tried lubing the threads a little ... quite often on the cheaper mods the threads are just rough as guts and need a little help... If you have Noalax or similar , give it a smear ... vaseline sparingly in a pinch if you have no conductive grease ?
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  5. #5
    Senior Member
    Join Date
    May 2010
    Location
    Clagiraba, Queensland
    Posts
    10,965
    i reckon mines often a 6 click vamo..
    phxrxonic likes this.
    In order of useful: Provari V2 and V1, vamo, eGo twist, Katana v3, Hex, Orion v2, LavaTube, eGo x 6, VMAX, 510N, Tick V2, Tick V1, noEgo 18650, noEgo 14650 , Indulgence x 2, 905 6v mod, KR808D



  6. #6
    Senior Member
    Join Date
    Mar 2013
    Location
    Queensland
    Posts
    1,160
    Whenever I get a new mod I get a good stiff toothbrush and some alcohol and give threads a good clean up. There is often grease caught in the gaps and there can be metal filings trapped in the grease as well. Make sure you get all of the grime out because grinding the threads on this stuff could cause further damage especially if there is a large chunk of metal caught in there somewhere.
    davee likes this.

  7. #7
    Senior Member
    Join Date
    Dec 2012
    Posts
    131
    I havent had trouble with my V2. The threads are fine. Also, I find that the click needs to be fast, so yeah sometimes it doesn't quite count your first click and you go to 6 clicks, or if you were too slow you go again and end up at 10 clicks to turn it on.

  8. #8
    AVF Newbie | Be nice to me
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    99
    Hmmm I think the threads on mine are dodgy, justa cave it a real good clean with both a toothbrush and later with a wire wheel to remove any debris, but nothing.

    I only bought it two weeks ago, so I'll ask the seller whether they can swap it for me :-/

  9. #9
    Senior Member
    Join Date
    May 2010
    Location
    Clagiraba, Queensland
    Posts
    10,965
    i think attacking it with a wire wheel could be a warranty voiding action personally.
    In order of useful: Provari V2 and V1, vamo, eGo twist, Katana v3, Hex, Orion v2, LavaTube, eGo x 6, VMAX, 510N, Tick V2, Tick V1, noEgo 18650, noEgo 14650 , Indulgence x 2, 905 6v mod, KR808D



  10. #10
    AVF Newbie | Be nice to me
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    99
    nah, i wouldnt imagine it. i just gave it a quick touch in an area that looked dodgy, by hand. didn't do anything unfortunately, same as the toothrbush :-(
    On top of that, i think It's not measuring correctly the watts. most people seem to run between 7 and 9 watts, I can only go up to 4.5 with my vivi novas or they taste burnt
    Last edited by casual; 13-04-13 at 02:47 PM.

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:22 PM.