Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Like Tree1Likes

Thread: smoktech rsst threads ???

  1. #1
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676

    smoktech rsst threads ???

    so I finally bit the bullet and got my first rebuildable.
    Havent set it up cos I dnt have time but screwed it on the provari to c the look of it. all I get is a half turn before it wont thread any further. There is an ugly gap between mod and tank, bout 1/2 cm
    next tried it on the anyvape cvi and it threads more turns but still a big gap, is this normal?
    im waiting on the natural telescope to be available locally to use with the rsst but wondering if I will still have this problem.
    I have cleaned the threads and retracted the positive post, still no difference

    Any info/help please

    tried uploading pics, but wont upload for sum reason

  2. #2
    AVF Regular
    Join Date
    Apr 2012
    Location
    Liverpool, Sydney
    Posts
    569
    Try checking the pin on the RSST, it may not be recessed enough.

  3. #3
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676
    Quote Originally Posted by chainsawttp View Post
    Try checking the pin on the RSST, it may not be recessed enough.
    tried that, makes no difference

  4. #4
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676
    RSST won't thread on my Provari

    just saw this, same problem.
    I also tried a 510 adapter and same problem, only a half turn
    tried noalox too


  5. #5
    AVF Regular
    Join Date
    Nov 2012
    Location
    Melbourne
    Posts
    1,309
    Must be the threads themselves, it could have a wonky starting thread or the first two lines

    if you look very closely you might be able to see the damadged thread part and maybe file it to a point where it screws on

  6. #6
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676
    Quote Originally Posted by SIMON@EcigModShop View Post
    Must be the threads themselves, it could have a wonky starting thread or the first two lines

    if you look very closely you might be able to see the damadged thread part and maybe file it to a point where it screws on
    ok
    I cant see anything but will give it a go
    thanks Simon

  7. #7
    Senior Member
    Join Date
    May 2012
    Location
    Tweed Heads........ # i vape 18mg#
    Posts
    2,088
    i must say my rsst fits great on my jazz e pipe, works well to boot

    it is a bit gapy on the provari but it dont bother me
    Living is easy with eyes closed, misunderstanding all you see.....im off to the PUB

  8. #8
    AVF Regular
    Join Date
    Apr 2012
    Location
    Liverpool, Sydney
    Posts
    569
    If you have a spare 510 connection, you could force tighten into it to tap the threads.. Last resort though.
    lozza 82 likes this.

  9. #9
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676
    Quote Originally Posted by chainsawttp View Post
    If you have a spare 510 connection, you could force tighten into it to tap the threads.. Last resort though.
    thats what I was thinking, I got a ego t 650 batt that's just layin around will try that l8r,

    tried a metal nail file to c if it would do the trick, nope

    if I get the night off work I will have a play around with better tools , right now gotta get ready for work

    thanks for help guys - I think the threads r the problem, they r a bit rough

  10. #10
    Senior Member
    Join Date
    Jul 2012
    Location
    melbourne
    Posts
    1,676
    ok got the night off, headed to bunnings and was planning on getting a die wrench kit to fix threads but the smallest one was 0.8mm- too big
    instead I got a small filing tool kit. Tinkered away filing and twisting on and off an ego T batt ...

    results
    Now sits flush on the anyvape cvi- awesome
    improvement on threads on the provari but still a generous gap


    new 028.jpgnew 027.jpg sorry crappy pics

    Will just have to wait and hope that when I get the natural telescopic mod it sits nicely

    I don't understand how it completely screws down on the anyvape and ego t but not on the provari or the 510 adapter when they are all the same connection- confusing
    Last edited by lozza 82; 07-05-13 at 11:48 PM.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:03 PM.