Results 1 to 7 of 7
  1. #1
    AVF Regular
    Join Date
    Nov 2013
    Location
    Mitcham S.A
    Posts
    709

    Kayfun Lite Clone leaking at the filler hole?

    Hi Guys,
    New to mods and this is my first one....
    I now have a kayfun lite clone + Chi You clone recently aquired from a forum member and have a quick question.
    I am yet to try it as i am waiting for a battery, but am finding there is a small amount of liquid sitting on the base of it, and the top of the mod when i take it off.
    Is this normal / worth trying to fix?
    While i'm at it, should the kayfun work on and ego twist?
    I have tried it but the battery light just flashes and nothing happens.
    Any advice appreciated as i hope a haven't just wasted cash.
    Cheers

  2. #2
    AVF Regular
    Join Date
    Jun 2012
    Location
    Sydney, Australia
    Posts
    1,303
    I think it's normal. It happens to me on occasion.

    As for why it won't work on the Twist the center pin probably isn't making good contact.

  3. #3
    AVF Regular
    Join Date
    Jul 2013
    Location
    Melbourne
    Posts
    3,048
    Was normal with mine too. If you get enough liquid in the airhole that it gurgles, just hold the kayfun upside down and blow into the airhole to clear it.
    supporter of genuine mods and attys


  4. #4
    Senior Member
    Join Date
    May 2013
    Location
    NANNY STATE W.A.
    Posts
    1,267
    Yep normal,get it in both my clones and real one.. not heaps just some weaping..I do the same as ssstahly..
    I VAPE = I LIVE

    Started Vaping at 16:00 hrs on 11th April 2013...
    Saved poop loads of $ not buying stinkies since then.
    Spending poop loads of $ on shinies and juice etc since then
    But now I am happy...


  5. #5
    AVF Regular
    Join Date
    Dec 2012
    Location
    SA
    Posts
    5,188
    as above really, hold upside down and blow. no leaking per se from the fill hole though

    as for the non working on an ego, maybe the coil is a bit low Ohm wise for the ego to work

  6. #6
    AVF Regular
    Join Date
    Aug 2012
    Location
    NE Victoria
    Posts
    2,255
    Definitely seems like a design fault as the later models come with a little rubber o ring for the screw.

    $3642 Spent on Vaping

  7. #7
    AVF Regular
    Join Date
    Nov 2013
    Location
    Mitcham S.A
    Posts
    709
    Thanks heaps for the replies guys,

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:17 PM.