Page 1 of 3 123 LastLast
Results 1 to 10 of 25
Like Tree11Likes

Thread: Vision 1300maH Fatboy Twisters........misbehaving badly

  1. #1
    AVF Regular
    Join Date
    Oct 2012
    Location
    Adelaide
    Posts
    163

    Vision 1300maH Fatboy Twisters........misbehaving badly

    These batteries are pretty much my mainstay now, I like them particularly because of their longevity and design. BUT, with recent purchases I've been experiencing a few 'premature deaths' with them after ~46 weeks of usage. This generally starts with the power button flashing spontaneously (and/or refusing to illuminate at all when pressed), followed by unsuccessful recharging attempts. In other words, a dead battery.

    I don't expect a ~$30 battery to last forever, but I do expect a bit longer than 6 weeks. Conversely, my less favoured Ego-C Twists (well over 18 months old) are still going strong, as are three Fatboys purchased ~12 months ago.

    Anyone had similar experiences?
    margyb likes this.

  2. #2
    Senior Member
    Join Date
    Aug 2013
    Location
    Esperance Western Australia
    Posts
    3,627
    Quote Originally Posted by Expat View Post
    These batteries are pretty much my mainstay now, I like them particularly because of their longevity and design. BUT, with recent purchases I've been experiencing a few 'premature deaths' with them after ~4–6 weeks of usage. This generally starts with the power button flashing spontaneously (and/or refusing to illuminate at all when pressed), followed by unsuccessful recharging attempts. In other words, a dead battery.

    I don't expect a ~$30 battery to last forever, but I do expect a bit longer than 6 weeks. Conversely, my less favoured Ego-C Twists (well over 18 months old) are still going strong, as are three Fatboys purchased ~12 months ago.

    Anyone had similar experiences?
    Sometimes its not the battery, its the charger. This has been my experience with a couple of twists. They didn't seem to want to charge, and even after fiddling around with the battery connection, wouldn't charge. I bought a couple of back up chargers, and tried charging them on the new charger, no problems at all. I don't know if you've tried this already, but if you haven't give it a try before you write off the twists

    The ego chargers don't last forever so it pays to have a couple of backup spares. Both the wall socket and the usb part
    All opinions expressed by me, are my own, I do not represent, or speak for, anyone but myself.






    STOPPED SMOKING 11/08/13 STARTED VAPING 11/08/13

  3. #3
    AVF Regular
    Join Date
    Sep 2013
    Location
    Alice Springs, NT
    Posts
    547
    I haven't had any dead ones yet but I have found irregularities in them. I have an eGo Twist 1100, an eGo Spinner "Fatboy" 1300 and just bought a Vision Spinner 1300 (eGo clone). They all behave differently when plugged into the charger. The twist binks 3 times than the light goes out.....and stays out. It charges fine. The eGo Spinner blinks a few time then the light comes on and stays on until it's fully charged and then goes out. The Vision Spinner blinks about 10 times and then goes out and stays out. All batteries charge to 4.8v.

    I'm pretty happy with them as batteries but I would like a little consistency. I'm assuming the eGo Spinner is behaving correctly as that's how the two 650 eGos that came with my crappy starter kit behaved. I'm red/green colour blind (like 25% of males) so I have trouble telling when a battery is charged by looking at the light on the charger....it looks pretty much the same to me whether it's red/orange or green.

  4. #4
    AVF Regular
    Join Date
    Sep 2013
    Location
    Alice Springs, NT
    Posts
    547
    Also where you plug the charger in can make a difference as well. I had trouble with a USB charger plugged into a powered USB hub the other week. It was putting out 3.8v and 4.2v when plugged into a wall adaptor. So plugged into your computer is not necessarily giving you a proper charge. It seems ok plugged into the computer USB port but didn't like the hub much.

  5. #5
    AVF Regular
    Join Date
    Oct 2012
    Location
    Adelaide
    Posts
    163
    Quote Originally Posted by spud View Post
    Sometimes its not the battery, its the charger. This has been my experience with a couple of twists. They didn't seem to want to charge, and even after fiddling around with the battery connection, wouldn't charge. I bought a couple of back up chargers, and tried charging them on the new charger, no problems at all. I don't know if you've tried this already, but if you haven't give it a try before you write off the twists

    The ego chargers don't last forever so it pays to have a couple of backup spares. Both the wall socket and the usb part
    Your comments are appreciated but don't explain why my older Fatboys (~12 months) are behaving immaculately, both in charging and usage. Its (some) of my more recent purchases which are giving me grief. And all of my batteries, Ego-Cs and Vision Fatboys, are charged off the same kit (three wall socket/USB combos).

  6. #6
    Senior Member
    Join Date
    Aug 2013
    Location
    Esperance Western Australia
    Posts
    3,627
    Quote Originally Posted by Expat View Post
    Your comments are appreciated but don't explain why my older Fatboys (~12 months) are behaving immaculately, both in charging and usage. Its (some) of my more recent purchases which are giving me grief. And all of my batteries, Ego-Cs and Vision Fatboys, are charged off the same kit (three wall socket/USB combos).
    Can't really help you then Expat, I've had no problems with my twists or spinners, only with the chargers. Hope someone else can help you solve the mystery
    All opinions expressed by me, are my own, I do not represent, or speak for, anyone but myself.






    STOPPED SMOKING 11/08/13 STARTED VAPING 11/08/13

  7. #7
    Senior Member
    Join Date
    Sep 2013
    Location
    Adelaide SA (west)
    Posts
    2,071
    I bought my 1300 vision spinner in Nov. and fear it's on the way out already.... it just stops working and then it'll start again sfter pushing the button a few ( thousands of) times, I have 3 usb chargers... one which is recommended for the spinner too so think it's the on/off as my egos charge okay .. just bad luck I guess, certainly not sending it back to china

  8. #8
    AVF Regular
    Join Date
    Oct 2012
    Location
    Adelaide
    Posts
    163
    Quote Originally Posted by maggie View Post
    I bought my 1300 vision spinner in Nov. and fear it's on the way out already.... it just stops working and then it'll start again sfter pushing the button a few ( thousands of) times, I have 3 usb chargers... one which is recommended for the spinner too so think it's the on/off as my egos charge okay .. just bad luck I guess, certainly not sending it back to china
    Ditto, Maggie. I've also experienced the same; on again/off again/on again ad infinitum. But, the bottom line is we're paying our hard-earned for these widgets. The least I'd expect in return is some consistency of product. And if we don't bring shortcomings to the attention of vendors/manufacturers, they'll probably think all is well in the world and have zero incentive to improve matters.

  9. #9
    AVF Regular
    Join Date
    Oct 2011
    Location
    Hobart Tasmania
    Posts
    5,658
    Where are you getting the vision spinners from?
    Just curious
    I just got 3 rainbow spinners from HC

  10. #10
    AVF Regular
    Join Date
    Jun 2012
    Location
    Gold Coast Qld
    Posts
    3,838
    I had one that's was 8 months old doing the same blinking thing an not charging...I git pissed off n threw it in the drawer for a few months...a month back I was told to put it on 4.2 ...plug it in an hold the button down for 10 -15 secs ( this has to be done on a joytech charger ) hey presto...back to good...something to do with resetting it...might be hocus pocus but its working fine now
    margyb, gtadmin and Blaktop like this.

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 05:36 AM.