Results 1 to 10 of 10
Like Tree2Likes
  • 1 Post By Sean
  • 1 Post By Altered1

Thread: Dead Battery

  1. #1
    AVF Regular
    Join Date
    Mar 2014
    Location
    On the Goldie!
    Posts
    270

    Dead Battery

    Okay, the battery in question is an eGo-CTwist 1100mah. I removed a clearo (iclear 30) from it, to clean said clearo, put a different clearo (iclear16) on it and... Nothing! Nada! Zilch!
    It's fully charged as of about an hour ago and about four weeks old. The LED does everything it's supposed to but putting a meter across the terminals shows ~0.25V. Changing voltage doesn't have any effect. It's acting like it's suddenly gone open circuit... the charger doesn't even see it!

    Has anyone else experienced this before? Does anyone have any suggestions?

    As it stands I'm down to using a cheapo 650mah batt with no back up until I can get to VC tomorrow.

    Bugger!

  2. #2
    AV Approved Manafacturer/Modder
    Join Date
    Mar 2010
    Location
    mostly in the shed
    Posts
    450
    bloody batteries
    soon you will have so many of them that one or two deaduns mean nothing
    all i can suggest with the twist battery is check that the post is clean and the oring is not damaged
    otherwise it toast

    this is my lazy morning so far
    check all batts with a multi and charge or throw
    while im waiting lets play coil rebuilding
    get a good resistance
    hit the power button
    hmm , ok , its on fire
    thats maybe no good now
    i love vaping
    its so fuss free and easy everyday

    the pic below isnt all the batts i have , just the ones im checking atm
    got 40 deaduns so far
    yay
    QUOTE=Fatman; I have licked many things ... some I am proud of , some I am not :(

  3. #3
    AVF Regular
    Join Date
    Mar 2014
    Location
    On the Goldie!
    Posts
    270
    Thanks billyboy. Looks like it's had it then...

    I really would expect a battery that has been well looked after to last more than a month though...

  4. #4
    Senior Member
    Join Date
    Aug 2013
    Location
    Perth
    Posts
    2,474
    Quote Originally Posted by Sean View Post
    Thanks billyboy. Looks like it's had it then...

    I really would expect a battery that has been well looked after to last more than a month though...
    You sure you got the battery voltage reading right?
    Some clearos, and iclear16 too IIRC, often need the pin pulled out (or the battery pin prised up) to get a good contact.

  5. #5
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Before you give up on it completely Sean .. have a read here ,, quite often the centre post on egos can get pushed down a little by over tightening ... and then it wont contact properly on another atty or combo

    Non firing Ego style battery (Add other ego tips here )
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  6. #6
    AVF Regular
    Join Date
    Mar 2014
    Location
    On the Goldie!
    Posts
    270
    100% sure coopz. I tested the other batt to compare. I tried the old pin prising trick too... no go.

  7. #7
    Senior Member
    Join Date
    Aug 2013
    Location
    Perth
    Posts
    2,474
    Ah well, that's a shame. I've never seen a dead battery/PCB that still light's up fine, must be a break or bad solder on the connections from the PCB to the 510.

  8. #8
    AVF Regular
    Join Date
    Mar 2014
    Location
    On the Goldie!
    Posts
    270
    I suppose so. I didn't drop/bash it so I suspect a dry dodgy joint may be the cause.

    ETA: Is it too late to hope for an Easter resurrection type miracle? Maybe if I give it three days...
    Last edited by Sean; 21-04-14 at 04:37 PM. Reason: Addition
    Fatman likes this.

  9. #9
    AVF Regular
    Join Date
    Oct 2013
    Location
    Melbourne
    Posts
    3,690
    You could always pry off the connection end and check the wires. It is interference fit into the case.
    Fatman likes this.




    Gaffer Tape is like The Force - it has a light side, a dark side, and it holds the universe together

    Without specific approval, No one has permission to quote me outside of AVF

  10. #10
    AVF Regular
    Join Date
    Mar 2014
    Location
    On the Goldie!
    Posts
    270
    Cheers Altered, I'll give that a try at work tomorrow when I have access to decent tools.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 02:32 PM.