Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jun 2010
    Location
    Latrobe Valley
    Posts
    26

    New iClear30B leaking at times... why?

    I'm having a problem with new tank I just bought...

    For some reason, with the original coil, it leaks like a SOB.

    since I changed the coil to a new one, it worked fine until I refilled it, then it would start leaking.

    What am I doing wrong? or is it a known issue with these iClear30B Clearomizers?

    I just bought a iClear X.I and wondering if I'm going to have the same fate.

    Thanks for reading.

  2. #2
    Member
    Join Date
    Feb 2014
    Location
    Rosewood QLD
    Posts
    47
    I have had this experience too with the 30B, I think when the liquid drops to a low level is when its seems to start leaking and flooding.

    The X.I uses the same coil, I haven't tried one yet??????

  3. #3
    Junior Member
    Join Date
    Jun 2010
    Location
    Latrobe Valley
    Posts
    26
    Quote Originally Posted by ados View Post
    I have had this experience too with the 30B, I think when the liquid drops to a low level is when its seems to start leaking and flooding.

    The X.I uses the same coil, I haven't tried one yet??????
    I bought an iclear x.i and it doesn't seem to leak.

    Have not had iclear x.i leak on me yet, but I haven't touched the tightness etc of the other parts... only the coil part.

    The iclear 30B has 2 stainless steel bits. the iclear x.i has 3

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 03:21 AM.