Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By Dicko

Thread: ehpro valkyrie screw up

  1. #1
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151

    ehpro valkyrie screw up

    urg, so i got mine yesterday, had the hot switch issue, fixed it, but still got slightly too warm , decided to grind it down, i over did the delrin. now it just auto fires, anyone got ideas for a quick fix

  2. #2
    Jas
    Jas is offline
    AVF Regular
    Join Date
    Mar 2013
    Location
    Melbz
    Posts
    3,358
    buy an original??
    The Glock 9mm has a historic legacy of reliability, performance, Power and perfection


    Vaping has just become apart of life, It will always be there until the very end.
    Official Vanilla custard extremist and connoisseur.

  3. #3
    AVF Regular
    Join Date
    Oct 2013
    Location
    Townsville
    Posts
    697
    Jas likes this.

  4. #4
    AVF Regular
    Join Date
    Dec 2013
    Location
    Melbourne, Eastern Suburb
    Posts
    971
    Quote Originally Posted by bronco View Post
    urg, so i got mine yesterday, had the hot switch issue, fixed it, but still got slightly too warm , decided to grind it down, i over did the delrin. now it just auto fires, anyone got ideas for a quick fix
    Honestly, Put it in the display section and leave it there. You might be able to find spare parts for it later down the track but i wouldn't use it as is.

  5. #5
    AVF Regular
    Join Date
    Aug 2012
    Location
    Waikerie South Aus
    Posts
    2,099
    I'll buy it hehe

    Sent from my C6603 using Tapatalk

  6. #6
    AVF Regular
    Join Date
    Jan 2014
    Location
    Port Stephens NSW
    Posts
    1,989
    Buy a original and use the delrin from it. Maybe a pic would help us see what can be done

  7. #7
    Senior Member
    Join Date
    Apr 2014
    Location
    Melbourne Victoria
    Posts
    782
    Quote Originally Posted by bronco View Post
    urg, so i got mine yesterday, had the hot switch issue, fixed it, but still got slightly too warm , decided to grind it down, i over did the delrin. now it just auto fires, anyone got ideas for a quick fix
    I got ya man been told it should be fine to get a few spares on the house with the next shipment, ill keep you posted and you can come pick one up when they arrive

  8. #8
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151
    its ok, i fixed it with a bit of duct tape. i just grinded it a tiny bit too much.

  9. #9
    AVF Regular
    Join Date
    Jun 2011
    Location
    Melbs
    Posts
    4,962
    Maybe email vicious ant??
    Move along!!! Nothing to see here.

  10. #10
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151
    its the clone ehpro version. highly doubt they wanna hear from me . lol.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:02 AM.