Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Hidden1

Thread: Do Clouper Cana's have over-charge protection?

  1. #1
    AVF Regular
    Join Date
    Jan 2014
    Location
    Sydney NSW
    Posts
    1,032

    Do Clouper Cana's have over-charge protection?

    Clone Purchase Disclaimer: I purchased a Clouper Cana recently, and the unit works awesome. I love the look and feel of it, and I'm now saving up for a real HANA mod.

    Im about to charge the device for the first time. I have a red AW IMR 18650 in there, but I'm going to try charging it via the USB port.

    Do these cloned devices have overcharge protection, or should I be cautious about leaving it on the charger too long?

    Is using my Samsung phone charger also something I should avoid using to charge the device?

  2. #2
    Senior Member
    Join Date
    Dec 2013
    Location
    Melbourne
    Posts
    357
    i charge mine every night before bed and i don't have an issue the light on the front wont go green but thats just the unit!

  3. #3
    AVF Regular
    Join Date
    Jan 2014
    Location
    Sydney NSW
    Posts
    1,032
    I charged my CANA overnight, and there's been no green light, only a red LED shining from inside the USB port. The battery bar on the main screen is full. The device works fine.

    Im leaving it on charge for a little while longer to see if the light turns green.

    How would I know if it is overcharging? Its not hot at all. Everything seems to be fine with it. Could it be the battery?

    The battery is about 2 years old (AW IMR Red 18650).

  4. #4
    AVF Regular
    Join Date
    Jan 2014
    Location
    Port Stephens NSW
    Posts
    1,989
    My two chana clones both charges fine and the light goes green when charged and I have checked with a multimeter and they are fine. If the charge light is not turning green I would check the battery volts with a multimeter to make sure it is not overcharging to be safe.
    PurpleVapes likes this.

  5. #5
    AVF Regular
    Join Date
    Jan 2014
    Location
    Sydney NSW
    Posts
    1,032
    Quote Originally Posted by Hidden1 View Post
    My two chana clones both charges fine and the light goes green when charged and I have checked with a multimeter and they are fine. If the charge light is not turning green I would check the battery volts with a multimeter to make sure it is not overcharging to be safe.
    I took the battery out and checked with the Provari Check Battery option. Its showing up as 4.2V

  6. #6
    AVF Regular
    Join Date
    Jan 2014
    Location
    Sydney NSW
    Posts
    1,032
    I think for now, Im going to charge it inside a LIPO bag just to be safe.

  7. #7
    AVF Regular
    Join Date
    Jan 2014
    Location
    Sydney NSW
    Posts
    1,032
    I'll be checking this again, but this sounds more like what is happening:

    Anyone have a Cloupor DNA30 and a Fasttech Hana Modz 30W Clone?

    LED lights in the USB charger are hard or impossible to see. Also, some have a red LED on while charging and turn on a green LED when the battery is charged, others only have two red which dim when the batter is charged.
    Pretty sure this is what happens, as Ive noticed that the red LED is more dim when the device is charged. I'll check it next time I charge it.

  8. #8
    roj
    roj is offline
    Member
    Join Date
    Jun 2011
    Location
    Melbourne, Australia
    Posts
    85
    I've had a 1st gen and a 2nd gen Cloupor - 1st gen had a green light... 2nd one didnt...

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:57 AM.