Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Like Tree6Likes

Thread: Problems with the provari

  1. #1
    AVF Regular
    Join Date
    Oct 2013
    Location
    Perth, WA
    Posts
    224

    Problems with the provari

    Hey guys, had my provari for probably 7 months now, and I'm having problems with it. Never until last night.

    Basically when I hit the button it doesn't fire, when I screw in the battery and the button flashes in recognition that one's been installed, I screw all the way in and it doesn't fire, no button light up, no power what so ever, but I just unscrewed it, just a touch, hit the button and it worked.. But that's not really good enough for me. I've never had this problem before. It also seems like the power is very underwhelming now.


    If you're not winning, you should be learning from loss.

  2. #2
    Senior Member
    Join Date
    Mar 2014
    Location
    Belfield, NSW
    Posts
    287
    Coil / Atomizer issue? hows the 510 connection? is the brass tarnished up?

  3. #3
    AVF Regular
    Join Date
    Jan 2012
    Location
    South Australia
    Posts
    17,417
    Have you cleaned the internal battery contact?



    ProVari Electronic Cigarette Maintenance - YouTube
    Fatman likes this.
    Colouring My World with Elegance
    Started Vaping 13th October, 2011

  4. #4
    lmb
    lmb is offline
    AVF Regular
    Join Date
    Jul 2013
    Location
    Melbourne
    Posts
    1,046
    Contact Provape, they offer a 12 month warranty on all items and will repair items out of warranty for a fee. You will have to pay for shipping to send it back to them. I'd send them an email and see if they can help you out remotely first.
    RIP VP

  5. #5
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Quote Originally Posted by Crisscross View Post
    Have you cleaned the internal battery contact?



    ProVari Electronic Cigarette Maintenance - YouTube
    I would put my money on this also

    Plus make sure the threads are clean on the bottom cap and the spring sits well in it
    Crisscross and Altered1 like this.
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  6. #6
    AVF Regular
    Join Date
    Jan 2012
    Location
    South Australia
    Posts
    17,417
    Quote Originally Posted by Fatman View Post
    I would put my money on this also

    Plus make sure the threads are clean on the bottom cap and the spring sits well in it
    I think it was FM that showed me this and it has become a weekly maintenance routine for ours. Including checking the threads on all our attachments. (Hippo's, twins, rings etc)
    Colouring My World with Elegance
    Started Vaping 13th October, 2011

  7. #7
    AVF Regular
    Join Date
    Oct 2013
    Location
    Perth, WA
    Posts
    224
    I'll have to take a better look and give it all a clean see if it changes, I don't have isopropyl or rubbing alc.... What could I use as an alternative.


    If you're not winning, you should be learning from loss.

  8. #8
    Junior Member
    Join Date
    Jul 2014
    Location
    Gloucester nsw
    Posts
    16
    I have an old provape one it stopped working
    cleaned internal contact all good again
    i would guess is your problem also
    hope it come good

  9. #9
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Quote Originally Posted by Shadzy View Post
    I'll have to take a better look and give it all a clean see if it changes, I don't have isopropyl or rubbing alc.... What could I use as an alternative.
    You could use a very fine grade of sandpaper on a stick or pen ... just make sure you blow it out well ... you just want to clean to expose metal , not grind it away LOL

    I would try first with a damp cotton bud ( not wet) just enough to loosen any grime
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  10. #10
    AVF Regular
    Join Date
    Oct 2013
    Location
    Melbourne
    Posts
    3,691
    Quote Originally Posted by Shadzy View Post
    I'll have to take a better look and give it all a clean see if it changes, I don't have isopropyl or rubbing alc.... What could I use as an alternative.
    Metho, vodka etc
    Fatman likes this.




    Gaffer Tape is like The Force - it has a light side, a dark side, and it holds the universe together

    Without specific approval, No one has permission to quote me outside of AVF

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 02:41 AM.