Page 1 of 3 123 LastLast
Results 1 to 10 of 25
Like Tree11Likes

Thread: Sigelei 50W owner.

  1. #1
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628

    Sigelei 50W owner.

    Just got two Sigelei 50W today, a few things I need to check with you guys.

    First: One says "check atomiser" when there is no atty attached and the other don't say anything, the writing on the screen just light up then dims after letting go of the firing button.
    Second: After removing the battery, the wattage goes back to 15W, it doesn't stay at the set wattage.

    Curious if you guys' are the same.
    Cheers, Don.

  2. #2
    AVF Regular
    Join Date
    Nov 2012
    Location
    Elizabeth Vale. SA
    Posts
    794
    mine says check atomiser when there is no atty on it and when i take out battery and put it back in it keeps my watt settings

  3. #3
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Just checked mine ( brand new today ) check atomiser comes on if fired with no atty ... removal of battery requires a 5 click to turn back on , but it remembered my setting .
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  4. #4
    AVF Regular
    Join Date
    Apr 2014
    Location
    Nanango
    Posts
    648
    Mine is the same as the previous two posters.
    I don't blow clouds. I might if they bought me dinner and made me feel appreciated every now and then...

  5. #5
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628
    Cheers guys, i'll look into it further.

  6. #6
    Senior Member
    Join Date
    Aug 2013
    Location
    Perth
    Posts
    2,474
    Mmmmm, these use the sx330 chip right?
    Might have different versions of the firmware.
    In my IPV V2 using a sx330 chip, it will not say anything with no atty attached, just light up with the fire button pressed like everything is normal. It will also default to 15w if the battery is disconnected for a little while.
    So for that mod you have, it behaves like a IPV2.

    The one that retains settings and says check atomizer is the same sx330 from what I beleive, and from what responses have been so far, is what the sigelei 50w mod is supposed to be programmed to do.
    So you mods seem to have different firmware.
    Last edited by coopz; 12-09-14 at 09:59 PM.
    Fatman and Bobthebuilder like this.


  7. #7
    Super Moderator
    Join Date
    Aug 2012
    Location
    Central Vic,up near the Murray
    Posts
    17,897
    Makes sense Coopz . I heard on the grapevine Segelie neatened up the firmware on the 50W after the first run ... replacing the +/- together push into a lock , rather than the touchbutton disable of the IPV2 , I would say the other changes are included in the latest revision ?
    EPM V2-18490 (X2 ),GP Spheroid V2.5 and GP Piccolo V2.5 ,BBCB, Provari mini's, REO mini V2.1, 18490 REO , Jazz Carto Pipes ( fitted with GA tank and churchwarden stem Totally Evil!!! ), Meerschaum pipe ,e-holly35W,Phideas, AIOS,Taifun atties, PC Pipe mods.PC Squonker, Svapiamo squonker, GP Paps Heron combo.

    Vaping since 2007 totally smoke free since 2011


    AVF Rules , Read and understand them

  8. #8
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628
    Quote Originally Posted by coopz View Post
    Mmmmm, these use the sx330 chip right?
    Might have different versions of the firmware.
    In my IPV V2 using a sx330 chip, it will not say anything with no atty attached, just light up with the fire button pressed like everything is normal. It will also default to 15w if the battery is disconnected for a little while.
    So for that mod you have, it behaves like a IPV2.

    The one that retains settings and says check atomizer is the same sx330 from what I beleive, and from what responses have been so far, is what the sigelei 50w mod is supposed to be programmed to do.
    So you mods seem to have different firmware.
    Yes got two today from the same place but one says check atomiser and keeps the wattage setting where the other one don't say anything and goes to 15W after removing battery. Both are sigelei 50W, so go figure, i am confused. The other thing with the faulty one is the led don't turn green when fully charged using the USB port, but as soon as I moved the batt to the other one the led turns green.
    How about the resistance jumping around? Has any of you experience this?

  9. #9
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628
    Quote Originally Posted by Fatman View Post
    Makes sense Coopz . I heard on the grapevine Segelie neatened up the firmware on the 50W after the first run ... replacing the +/- together push into a lock , rather than the touchbutton disable of the IPV2 , I would say the other changes are included in the latest revision ?
    Yes FM i checked that as well, pressing the + button and the fire button at the same time it will say "touch on" and the - botton and the fire button will say "touch off" and pressing the + and - will lock the device.
    Looks like i might get the first batch thus these problems.

  10. #10
    Senior Member
    Join Date
    Aug 2013
    Location
    Perth
    Posts
    2,474
    Quote Originally Posted by hun113 View Post
    Yes got two today from the same place but one says check atomiser and keeps the wattage setting where the other one don't say anything and goes to 15W after removing battery. Both are sigelei 50W, so go figure, i am confused. The other thing with the faulty one is the led don't turn green when fully charged using the USB port, but as soon as I moved the batt to the other one the led turns green...
    My IPV2 doesn't go green either. used the onboard charging for the first time last night. Red while charging, nothing when charged (ie no green light).

    YiHi, the manufacturers of the sx330 board, supply their boards to both sigelei 50w and p4y/green leaf for their IPV2 50W box mods. Seems one of yours has the IPV2 set up.
    Last edited by coopz; 12-09-14 at 10:41 PM.


 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 10:58 AM.