Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Like Tree5Likes

Thread: Rose v2 clone impressions

  1. #1
    AVF Regular
    Join Date
    Nov 2012
    Location
    Elizabeth Vale. SA
    Posts
    794

    Rose v2 clone impressions

    So I got the rose v2 clone from New Products | VapourEyes and here is what i have so far

    Looks good nice looking RTA. Comes with clear section and stainless steal section also some extra o-rings and 2 ceramic cups
    Its a bit of a fogger t-fun tank

    So building it hasn't been easy for me, being a bit fiddly and i dont think anyone with bad eye site or shaky hands would like having this RTA. I had trouble with getting the coil in and I found that taking out the screws that hold the coil lets me see if the coil is in the right holes as I a few times I had a coil leg bend. Also found that its not easy to wick as the deck in a cup like the fogger but unlike the fogger the sides dont drop down.

    Also and I don't know why but my builds come out 1ohm extra don't know why this happing but it does and that's of 2 different rose v2 clones im sure someone smarter than I knows why this is the case.

    The vape is smooth or easier than on a kayfun clone its the only words i can think of to say hows the vape is. Flavour is good i have to use Japanese cotton in the build so its equal to my kayfun builds that use German cotton yarn witch is so far for me the best tasting cotton that I got my hands on.

    There is next to no flooding for me or leaking through the air hold.

    As for juice control i don't see the need for it and its a pain in the ass to get it set i use 50/50 juice and so i find it not needed also note cause of the juice control you cant use different drip tips.
    steve.c likes this.

  2. #2
    AVF Regular
    Join Date
    Jun 2014
    Location
    Brisbane
    Posts
    1,450
    I see it doesn't come with the atty stand tool which helps get the Rose dismantled. Have you had any trouble separating the bottom bits?
    Thanks for the review Monz.

  3. #3
    AVF Regular
    Join Date
    Apr 2013
    Location
    Melbourne
    Posts
    1,549
    No resistance issues on the original. Something go wrong during the cloning process?

    ssstahly and Stewey like this.
    ಠ_ಠ

  4. #4
    AVF Regular
    Join Date
    Nov 2012
    Location
    Elizabeth Vale. SA
    Posts
    794
    the tools for the rose v2 clone arnt not really needed i have found easy enough to undo everything without them

  5. #5
    AVF Regular
    Join Date
    Jun 2014
    Location
    SW Victoria
    Posts
    3,808
    Tighten the coil screws, that'll be the resistance problem. You don't need the stand. Any stand will do or the top of your mod.

  6. #6
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628
    I have 3 rose v2 clones by infinite and none of them have the resistance issue.

    Yes they are fiddly at first and almost threw them to the wall with my first build, but I tore em off the next day, built 3 of them again and I found its much easier and with half the time.
    Watch this one http://m.youtube.com/watch?v=db1MxwuctkQ it really helped me with my build.

    You don't really need the stand to tighten it down however I'm thinking of getting one of this this weekend, for only 3 bucks you can't go wrong

    Or wait till vapour eyes got the Tobeco rose v2 with base which according to their site is coming on the 20th October.

  7. #7
    Senior Member
    Join Date
    Aug 2014
    Posts
    177
    ive got the same rose v2 clone and was having the same troublw with resistance until I unscrewed the bottom part with the air flow hole and tightened the screw just below the white delrin bottom, now its reading fine
    merexy likes this.

  8. #8
    AVF Regular
    Join Date
    Nov 2012
    Location
    Elizabeth Vale. SA
    Posts
    794
    i tryed the pin thing nothing changed so ill have to live with the 1ohn extra

  9. #9
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    628
    Have you tried cleaning the grub screw hole Monz? I have found with mine it has small bits of metal. Could that be the cause of the extra resistance?

  10. #10
    AVF Regular
    Join Date
    Jun 2014
    Location
    SW Victoria
    Posts
    3,808
    Quote Originally Posted by luntingsir View Post
    No resistance issues on the original. Something go wrong during the cloning process?
    At $231 plus shipping there shouldn't be any issues with the original.
    luntingsir likes this.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:18 AM.