Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Jul 2014
    Location
    Geelong, VIC
    Posts
    29

    Problem with ego v-v2 MEGA

    Hey Guys,
    I have been vaping for a while now and decided to try out an RDA, so i bought an IGO-W and built some coils for it.
    When im using the IGO-W on my Ego V-V2 Mega it shuts off after about 10 seconds - which is normal, but on the following puff it shuts off after about 6 seconds, on the next puff about 3 seconds, then on the next about 1 second. If i leave it sitting for a minute it goes back to normal.
    Any ideas what's causing this? And how can i fix it?
    This doesnt happen with my EVOD or Protank

  2. #2
    AVF Regular
    Join Date
    Aug 2012
    Location
    Waikerie South Aus
    Posts
    2,099
    Not 100% sure but could be overheating

  3. #3
    Senior Member
    Join Date
    Jul 2014
    Location
    Bribie Island
    Posts
    359
    Quote Originally Posted by yatesy88 View Post
    Not 100% sure but could be overheating
    Yep . Coil too low for your ego me thinks.

  4. #4
    Junior Member
    Join Date
    Jul 2014
    Location
    Geelong, VIC
    Posts
    29
    Too low? This is happening even on 1.8 Ohm coils, do the coils lose resistance when they get warm? Because that could make sense..

  5. #5
    Junior Member
    Join Date
    Jul 2014
    Location
    Geelong, VIC
    Posts
    29
    Actually i just checked the coil and it is 1.4 Ohm. Is that too low for my Ego? If it is..then why does it work perfectly for the first puff?

  6. #6
    Senior Member
    Join Date
    Jul 2014
    Location
    Bribie Island
    Posts
    359
    Quote Originally Posted by yatesy88 View Post
    Not 100% sure but could be overheating
    Gradually getting hotter is my guess. Whats your battery rated for. Probably should be using a mech or vv/vw device.

  7. #7
    Junior Member
    Join Date
    Jul 2014
    Location
    Geelong, VIC
    Posts
    29
    The ego v v2 is a Vv battery.
    I cant find the minimum resistance for the ego v v2 anywhere.
    How would the battery know that the rda is overheating?

  8. #8
    AVF Regular
    Join Date
    Dec 2012
    Location
    Off grid, quietly hermity, NW Tas
    Posts
    6,476
    Do you have specs?
    An actual brand and model?
    a PIC?


  9. #9
    Senior Member
    Join Date
    Jul 2014
    Location
    Bribie Island
    Posts
    359
    OK Lets start again What we/I am trying to say is that your battery is overheating by supplying too much current to your RDA. Then it starts to shut down. Then it cools off and works again. Is the top of your ego getting hot? Is this a no name china job (battery)?

  10. #10
    Junior Member
    Join Date
    Jul 2014
    Location
    Geelong, VIC
    Posts
    29
    Ohhhhh the battery overheating I understand now.
    I bought the battery from here: EGO-V V2 Variable Voltage Passthrough Battery
    After doing a bit more research on RDAs and ego style batteries its not reccomended to go below 1.8ohms so I will make a higher coil tomorrow and see how it goes.
    Would a vamo v5 be a good purchase for rda's/rba's?

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 12:04 PM.