Results 1 to 3 of 3
  1. #1
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sunshine Coast
    Posts
    305

    Centre Post Issues

    This may sound dumb,but some of my RTA,s centre posts are not protruding slightly past the 510 threading .
    when tightened some are actually inside the lip of 510 thread ,i have tried to loosen and that in turn loosens the positive terminal at the coil (not good).
    Looking at inserting a small delrin washer between centre post screw head and oem insulator ,
    Any thoughts,

    Lemo, some kfuns, russian .
    Last edited by Oldhead; 15-01-15 at 10:37 AM.

  2. #2
    AVF Regular
    Join Date
    Aug 2014
    Location
    Melbourne
    Posts
    174
    It certainly can be done, it's very fiddly making a small washer, that's the only way you would get one thin enough, but if your atties are making contact then don't bother too much

  3. #3
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sunshine Coast
    Posts
    305
    This is my reasoning, Just noticed after installing Kfunv4 , that my ohms are jumping on most of my VW devices.
    Double checked and it seems that (1)possible wear on internal threads of Device due to useage ) (2) metal compound of 510 on devices is lacking)

    Elimination process.
    RTAs coil ohm,s confirmed via volt meter and ohms test meter.
    Screw RTA ,to device and tighten , most times the VW device confirms previous test results (ohms are stable) but after some use the ohms start to be eratic ,and i have found that the rta only needs to be slightly moved or pushed and the ohms become unstable.???????
    Tighten the rta just a smidgin again, and it stabilizes.??????? This is suggesting to me that the contact point (centre pin & Poss contact is not as good as it should be)
    I don,t want to overtighten RTA,s and strip threads and i understand that Kfuns,Russians etc are tall and heavy, but the lemo is light and still does this.
    Typically happening to Sigelei 50watt and Eleaf mini 20watt ,IPV 50watt ,does not seem to happen to Sigelei Vmax ,though the Vmax has a well made S/S 510 threading.
    Im aware that Sigelei 50watt had issues and that Eleaf mini has inferior metal threading ,but this issue has only just started after many months of continual use..
    Looking for advice and or fixes .
    Just ordered some Fatdaddy V4 and V3 510 conn for trials.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 07:06 AM.