Results 1 to 9 of 9
Like Tree7Likes
  • 1 Post By hoonaberry
  • 3 Post By Kaoself
  • 2 Post By Skoville
  • 1 Post By crispy

Thread: Kamry K-1000 moded

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    22

    Kamry K-1000 moded

    Hi,

    Have own this Kamry K-1000 for a while and buy! so much trouble I went through...

    Problem I had with this mod are:
    • bottom coil spring under the battery heat up and melted insulating plastic and shorted the battery
    • connector to atomiser insulator damaged and shorted the mod
    • wire that connects the bottom coil connects to battery melted as coil heats up

    So I modified this mod as this. Probably the cheapest way too.

    Attachment 17429

    attached coil on a wooden base that dosen't melt and replaced to a thicker wire.

    Attachment 17430

    Attachment 17431

    Replaced rubber insulator with hard plastic tube and inserted rubber 0 ring for better connection and prevent damage on plastic tube from over tightening the atomiser.
    Worked flawlessly for last few months without any problems.

    Happy vape!
    Fatman likes this.

  2. #2
    AVF Regular
    Join Date
    Jul 2014
    Location
    Melbourne
    Posts
    493
    I'm getting "Invalid Attachment" messages.
    steve.c, LimeB and crispy like this.

  3. #3
    AVF Regular
    Join Date
    Aug 2014
    Location
    Blacktown, Western Syd.
    Posts
    825
    yup - me too
    steve.c and crispy like this.

  4. #4
    AVF Regular
    Join Date
    Dec 2014
    Location
    adelaide south
    Posts
    235
    And me three
    steve.c likes this.

  5. #5
    AVF Regular
    Join Date
    Sep 2013
    Location
    Sydney
    Posts
    4,054
    Yup, invalid. Try again.

  6. #6
    Junior Member
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    22
    Sorry guys, I just found out that attached images are not working. I'll fix it up ASAP when I have spare time. :-)

  7. #7
    AVF Regular
    Join Date
    Aug 2014
    Location
    Melbourne
    Posts
    174
    I'm not fussed about the images, but why did it get hot enough to melt stuff? There has to be some shorting happening, modifying will only lead to battery safety problems!

  8. #8
    Junior Member
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    22
    Still donno why... Could be shorting that cause the problem whichever way it happen. However I found mechanical mod can be risky to use and moved to protected circuit VW mod as I feel safer using it.
    By the way, rubber insulator on 510 connection is too week and can be broken too easily. I have replaced it with plastic tube and a rubber o-ring.

  9. #9
    Junior Member
    Join Date
    Apr 2014
    Location
    Sydney
    Posts
    22
    I finally figured out why the spring heated and melted plastic insulator located on the bottom of the spring. I rebuilt my coil and multi-meter I was using gave me wrong reading somehow. I built 1.8ohms coils I thought and it actually was 1.2, where the crap battery supplied with this mod was unable to handle it and shorted itself?
    That is the only possible answer at the moment.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 08:41 PM.