Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35
Like Tree9Likes

Thread: Lemo Issues

  1. #1
    AVF Regular
    Join Date
    Jul 2014
    Location
    Sydney
    Posts
    508

    Lemo Issues

    Edit:
    I managed to solve my issue by changing how I build....rather than using the bunny ears method (putting the lower bell on then pushing the cotton down); Instead I would trip the cotton to the bottom of the deck, wet it in place then put the lower bell on and push the cotton against the upper deck to make sure the channels were clear,

    Hi all;

    I got a lemo a few weeks back but having been having some issues with the builds in it from day one. It produces a good amount of vapor and no issues of wicking or leaking. But I've found compare to other RTAs I have used it gives a very harsh vape with relatively poor flavour. Since everyone seems to talk about how great this tank is I figure I must be doing something wrong with is. I haven't used an RTA with a kayfun like bell before this and my KF4 clone(which was passed on as the damn thing wouldn't stop leaking and was a pain generally). Anyone have some thoughts?
    So here is the build I have in at the moment, the same I use in my AGA-T5 with great success. 27g, 0.8/0.9 ohm, 2.5mm wicked with rayon in this case (same problem with japanese cotton though)

    Last edited by nanokatz; 27-02-15 at 10:23 PM.

  2. #2
    AVF Regular
    Join Date
    Jun 2014
    Location
    Mandurah WA
    Posts
    217
    Fairly underwhelming response. I too found the Lemo to be harsh, initially. But i was running 15mg juice. Since dropping back to 9 or even 6,to cater for the Flamin Atlantis, i have been enjoying the Lemo. Been using mine on a Mech still with the original coil and it hits just right.

  3. #3
    AVF Regular
    Join Date
    Sep 2013
    Location
    Sydney
    Posts
    4,054
    Could it be your ohms? That's a sub ohm coil your running. Are you used to sub ohming? That tends to be a harsher vape.
    Last edited by steve.c; 25-02-15 at 10:15 PM.

  4. #4
    AVF Regular
    Join Date
    Jul 2014
    Location
    Sydney
    Posts
    508
    Quote Originally Posted by steve.c View Post
    Could it be your ohms. That's a sub ohm coil your running. Are you used to sub ohming? That tends to ba a harsher vape.
    Yeah I use that same coil in my aga t5 as I noted as well as some drippers. Don't have an issue there even with the same batch of liquid.
    That's why I assume its something about the lemo that I'm not getting right.

    In response to the previous comment I generally vape at 4 mg these days and don't have an issue even if using a dripper that produces serious clouds.

  5. #5
    AVF Regular
    Join Date
    Jun 2014
    Location
    Townsville
    Posts
    1,417
    I dunno, it looks ok from the top, height of the coil from the deck can make a difference as well as the wicking. If the coil is too low it will impede the airflow but if it is too high it will be a harsher hotter vape. I usually use 26g 7-8 wrap 3.2mm spaced coils in mine and I run them at 30w and don't find it to be a harsh vape. I have experimented with contact coils and spaced coils and found spaced coils seem to give the best vape for me in the Lemo. You need to get the wicking right though to avoid dry hits at higher wattage, the wick should be tucked back against the deck away from the juice channels. I'm due for a rewick later tonight so I can post some pics of my setup if you like.

  6. #6
    AVF Regular
    Join Date
    Jul 2014
    Location
    Sydney
    Posts
    508
    I've tried it closer and further from the air hole with no joy. That build was a little further. Wickin is a possible issue so if you can post your build I'd appreciate it

  7. #7
    AVF Regular
    Join Date
    Dec 2013
    Location
    Marrickville NSW
    Posts
    2,949
    I use 26g kanthal, with the coils spaced further apart than you have them.
    No dry hits.

  8. #8
    AVF Regular
    Join Date
    Jun 2014
    Location
    Townsville
    Posts
    1,417
    Actually here is a good picture of wicking that I posted a while ago in a dna40 thread. This is using ni200 wire but its pretty much the same build as I do with 26g kanthal.

    disley likes this.

  9. #9
    AVF Regular
    Join Date
    Jul 2014
    Location
    Sydney
    Posts
    508
    Quote Originally Posted by J_B_86 View Post
    You need to get the wicking right though to avoid dry hits at higher wattage, the wick should be tucked back against the deck away from the juice channels. I'm due for a rewick later tonight so I can post some pics of my setup if you like.
    So I tried moving my coil as close as I can to the airhole and that didn't change much. But I'm reading your response again. I may have an idea. I've been feeding the wick down using tweezers so the end goes into the channel. It doesn't fold back like you say you do. Next time I drain the tank I'll try that and see what happens.

  10. #10
    AVF Regular
    Join Date
    Jun 2014
    Location
    Melbourne, Western Suburbs
    Posts
    342
    I push my wick against the side wall of the upper deck, so the channels are clear which works for me
    Snidely_Whiplash likes this.
    "Vape mail incoming, I have"

 

 
Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 02:10 PM.