Results 1 to 6 of 6
  1. #1
    AVF Regular
    Join Date
    May 2014
    Location
    Melbourne
    Posts
    1,002

    Smok Xpro M80 not firing at proper power

    got my smok today, had the arctic and delta on it all day, then decided to try an RDA on it , tried 2 different RDA's one with a .33 build another with a .5 build.

    if i have it set to 44-45 watts or under it fires fine, if i go OVER 45 watts it wont fire any higher than 2.7v, its advertised to work down to .1 and up to 80 watts so i dunno whats goin on, weither i got a faulty one or am i missing something.

    anyone else have a simmilar issue?

    Big thanks to Hidden1 for his awesome work on my box mod! (vapeOholic ejuice is my crack/cocaine)

  2. #2
    AVF Regular
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    1,830
    Quote Originally Posted by nukem View Post
    got my smok today, had the arctic and delta on it all day, then decided to try an RDA on it , tried 2 different RDA's one with a .33 build another with a .5 build.

    if i have it set to 44-45 watts or under it fires fine, if i go OVER 45 watts it wont fire any higher than 2.7v, its advertised to work down to .1 and up to 80 watts so i dunno whats goin on, weither i got a faulty one or am i missing something.

    anyone else have a simmilar issue?
    Have a look at the M50/65 thread I seem to remember disley and northerner having a similar issue and was something to do with the batteries they used

  3. #3
    AVF Regular
    Join Date
    Dec 2013
    Location
    Marrickville NSW
    Posts
    2,949
    The M65 drops 5 watts if the device is cold.
    Once it reaches body temp it's fine.
    Why is this so?

  4. #4
    AVF Regular
    Join Date
    May 2014
    Location
    Melbourne
    Posts
    1,002
    the m80 has inbuild lipo 18650s tho so unfortunately i cant change them lol. well i have a suspicion there is quite a low amp limit which was not stated on their advertisement.. lame

    Big thanks to Hidden1 for his awesome work on my box mod! (vapeOholic ejuice is my crack/cocaine)

  5. #5
    Member
    Join Date
    Dec 2014
    Location
    Sydney, Australia
    Posts
    41
    I saw a post somewhere the other day stating something along the lines that after testing, the m80 cannot hit a true 80watts, it came out to somewhere around half of that. If this is true, Smok have a lot to answer for.

  6. #6
    AVF Regular
    Join Date
    Jan 2015
    Location
    Griffith, NSW
    Posts
    3,424
    At least 2 reviewers had their m80 die after testing. i think they rushed the model to market before the CYN.
    Apparently firmware update will fix alot the problems when its released

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 03:55 AM.