Results 1 to 5 of 5
  1. #1
    AVF Regular
    Join Date
    Apr 2011
    Location
    Melbourne
    Posts
    520

    Vapor Flask weak battery

    My two week old vapor flask has developed a fault. Newly charged batteries after one hour of vaping give a weak battery on the display. Vape it for 10 more minutes and fully charged seems like there a poor connection somewhere. Read on the internet it is most likely a lose ground connection screw connecting to the atomiser. But to fix it I need to open it up and void the warranty any ideas would be appreciated.


    Current gear: Provari, Zenesis *ASH*, Zenesis standard, ZAP, REO VV and Grand, Zenesis Sidewinder, Penelope, GG TS, Ithaka.

  2. #2
    AVF Regular
    Join Date
    Feb 2013
    Location
    Broady - MELB - VIC
    Posts
    3,481
    Is it authentic? If so contact your place of purchase to get it fixed.


  3. #3
    AVF Regular
    Join Date
    Aug 2013
    Location
    Brisbane
    Posts
    572
    mine developed the same problem within first battery cycle. Vf is aware of this problem (bad batch) and was going to send out a replacement two months ago and finally has posted on 3rd April (only words, no tracking yet). Goodluck!

  4. #4
    Senior Member
    Join Date
    Nov 2011
    Location
    Australia
    Posts
    4,055
    It's a universal DNA40 issue. Not a flask issue.

  5. #5
    AVF Regular
    Join Date
    Jan 2015
    Location
    Melbourne VIC
    Posts
    1,183
    Lucky it's just that, mine completely karked it after two and a half weeks of usage, still waiting for them to send it back my way. Defs selling it when it comes back haha

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 05:30 AM.