Results 1 to 10 of 10
  1. #1
    AVF Regular
    Join Date
    Oct 2014
    Location
    French country side
    Posts
    1,548

    VS rDNA dies after 5 mths

    To my horror I pulled out my VSrDNA after putting it down for 1 hr and nothing it won't fire up the atty. it shows stealth mode but I have done everything according to instructions to unlock it and it stays locked.

    If I press -+ it gives me read out that atty is locked. Any combination of buttons suggested doesn't work. Even lressing 5 times it locks and pressing again, it unlocks but won't fire. Blue light comes on as well.

    Checked battery, changed, replaced, changed again, charged with USB....nothing.

    Over $200 for a mod that dies after 5 months just hurts.
    I will be travelling in time, please leave a message and I will get back to you last week.




  2. #2
    AVF Regular
    Join Date
    Jun 2014
    Location
    Brisbane
    Posts
    1,450
    And I suppose the Guarantee has run out. With the paint problems of the mini SX & VS release problems it makes me wonder about these supposedly top quality mods.

  3. #3
    AVF Regular
    Join Date
    Sep 2014
    Location
    Bingil Bay, QLD
    Posts
    3,313
    I feel for you. (and know the feeling myself)

    Go back to mechs mate... no more tears.

  4. #4
    AVF Regular
    Join Date
    Aug 2010
    Location
    Neerim VIC
    Posts
    136
    Have you swapped the coil, I have a DNA40 clone that would function normally but wouldn't fire, turned out it was the atty.
    Beyond Vape Silo Tank - VF Clone

  5. #5
    AVF Regular
    Join Date
    Jul 2011
    Location
    Melb
    Posts
    5,139
    And thats why mech mods will always be king.

  6. #6
    AVF Regular
    Join Date
    Dec 2013
    Location
    Marrickville NSW
    Posts
    2,949
    That's a bummer, they're not cheap, and seem to have too many flaws.
    Although a lot of owners would say you were lucky to get 5 months out of one.

  7. #7
    AVF Regular
    Join Date
    Jun 2014
    Location
    Townsville
    Posts
    1,417
    Had mine for 6 months old now and it has copped an absolute hammering, the paint job is not looking too good but I haven't had any of the other problems with it. Mine definitely appears to be an exception to the rule though and who knows when it will eventually fail.

  8. #8
    AVF Regular
    Join Date
    Feb 2014
    Location
    Western Sydney, NSW
    Posts
    972
    My VS DNA30 main fire button died about 3 days out from the warranty date (3 months) ... Can't remember the email exchange with VS but the end thought was "why bother" - nice looking device, but overly complicated for what it needs to do (IMO!)

  9. #9
    AVF Regular
    Join Date
    Aug 2013
    Location
    Sydney Australia
    Posts
    3,577
    Hey cc, what are you going to do with it? If it's a paperweight, I could have a look at it for you? Maybe bring it tomorrow? No promises but my Dad always said, you can't always fix things, but you can always out it back together broken.............

  10. #10
    AVF Regular
    Join Date
    Dec 2014
    Location
    Melb
    Posts
    202
    My first one shit its self with the screen glitch and got fixed, now it wont charge. Luckily it's still under warranty and there just sending me a new one.. I feel your pain mate, never again am I paying top $ for a prototype mod.
    I would contact vs and talk to them, cant hurt to ask?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:07 AM.