Page 1 of 3 123 LastLast
Results 1 to 10 of 21
Like Tree5Likes

Thread: Aspire Atlantis Coils faulty?

  1. #1
    AVF Newbie | Be nice to me
    Join Date
    Jul 2015
    Location
    Sydney
    Posts
    27

    Question Aspire Atlantis Coils faulty?

    Hey guys, been vaping for a month or two now, and don't smoke very often at all (never had the addiction to nicotine and do it for the flavour since I only ever smoked shisha), hence I have been using the same coil for that duration of time. To give you a better idea of my usage of the coil, I have only refilled the tank 5 or 6 times with that same coil in it. Anyway, at the beginning it was perfect, big clouds, great flavour, the land of milk and honey. After a while I decided to change the coil, and the replacement coil did not whick and I just got a burnt taste straight away. I let the coil soak in a lot of juice, through each hole and on the cotton itself, it was basically drenched. With the tank half full, even after primer puffs, it did not whick. No bubbles. don't know what the go is but it seemed to me it was a busted coil? I threw it in a airtight plastic bag and didn't think too much about it. After a while of using the old coil again (which worked perfectly for a while) today I decided to try and use the same coil I had tried the last time, with good reason, the cotton had begun to blacken, along with the coil of canthal itself (or whatever atlantis coils have in them, this is not the v2).

    As I bought the aspire platinum kit from x vendor, I have five spare coils that I can throw into my setup... The kit is authentic and genuine (I checked online and all)

    Does anyone know what the problem is? could it be the juice itself? It worked with the other coil? I believe all the coils including the one that was first used was and are 0.5 ohms. Also I let that coil sit in juice so it doesn't get damaged (as instructed by the packaging) so it was never outside of juice or anything for it to dry out or who knows what..

    Anyways enough waffling, someone please help me
    Please and thank you

    ~ Sincerely, the vaping apprentice

  2. #2
    AVF Regular
    Join Date
    Jan 2015
    Location
    Melbourne VIC
    Posts
    1,183
    You probs just got a dud coil, it sometimes happen with pre made coils... just try a new one.

  3. #3
    AVF Newbie | Be nice to me
    Join Date
    Jul 2015
    Location
    Sydney
    Posts
    27
    I just threw in another coil and did the same process, keep getting this terrible taste, even after letting it sit for 20mins (this one actually showed bubbles of wicking) I'm confused, the first coil the tank came with worked perfectly after priming and wicking, and now two of my replacement coils are being retarded... Not very impressed at all to say the least.. Is this normal? the taste is unbearable, and even after 4-5 puffs I just don't taste any of the juice.

  4. #4
    AVF Newbie | Be nice to me
    Join Date
    May 2015
    Location
    sydney
    Posts
    20
    What PG/VG ratio are you using?
    How many watts are you vaping them on?

  5. #5
    AVF Newbie | Be nice to me
    Join Date
    Jul 2015
    Location
    Sydney
    Posts
    27
    To clarify I am using the same e-juice this whole time, a 70VG/30PG blend of 'Time bomb - joker', it worked wonders on the first coil which was 0.5 ohms and came inside the tank in the kit. Every coil since has been off, completely off, and I haven't even changed anything from the way I did it with the first coil. I vape on the aspire platinum kit which comes with the atlantis v1 and the aspire cf sub ohm battery (which doesn't have a dial to change the watts, but is variable wattage I believe)
    I have no idea what it is now... 2 faulty coils in a row? I fail to believe it. I donbilibit.

    *Edit - all replacement coils which come in the kit are also 0.5 ohms*

  6. #6
    AVF Newbie | Be nice to me
    Join Date
    May 2015
    Location
    sydney
    Posts
    20
    Try vaping it on the lowest setting. If that works slowly increase it till you're satisfied.

  7. #7
    AVF Newbie | Be nice to me
    Join Date
    Jul 2015
    Location
    Sydney
    Posts
    27
    there are no settings on the mod, for further reference, this is what I have

    Aspire - Aspire Platinum Kit

  8. #8
    AVF Newbie | Be nice to me
    Join Date
    May 2015
    Location
    sydney
    Posts
    20
    Sorry about that. Was looking at one with VV.
    Hope someone can help you. Otherwise I think you have the best luck in the world lol

  9. #9
    AVF Regular
    Join Date
    Jul 2015
    Location
    South West (WA)
    Posts
    1,015
    I had a dry hit on my Aspire Nautilus and the taste stayed with the tank and my mouth for a day. I had to wash the tank, throw out the juice, brush my teeth and start again.

    Only after taking a break for a few hours and then letting the tank sit for a while did it improve.

    Horrible.

  10. #10
    AVF Newbie | Be nice to me
    Join Date
    Jul 2015
    Location
    Sydney
    Posts
    27
    I don't think it's a dry hit though, the first time it happened I cleaned the tank and put the old coil back in and it tasted fine, only problem now is I have busted up that coil to see how it was built and what not, and it was
    a bit burnt so it was a good thing so it was a good thing I got rid of it. Atm this problem is just preventing me from using my vape completely, and what I thought would be a simple fix of replacing the coil did not work... I don't intend on trying every damn coil that was provided till I get one that magically works either :l
    Student life... oh the agony

 

 
Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 11:18 AM.