Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35
Like Tree7Likes

Thread: JOYETECH EVIC-VT 60W killing clearomizres

  1. #1
    AVF Newbie | Be nice to me
    Join Date
    Jan 2013
    Location
    Blacktown, NSW
    Posts
    37

    JOYETECH EVIC-VT 60W killing clearomizres

    guys

    yesterday i got my JOYETECH EVIC-VT 60W and since then it killed 2 of my clearomizers.

    i noticed that whenever i press fire button the inside if clearomizer gets really hot and turns firey red and i get burn smell and after a while it stops working.

    i am running JOYETECH EVIC-VT 60W at 2.8 w

    any idea??

  2. #2
    AVF Regular
    Join Date
    Jan 2015
    Location
    Griffith, NSW
    Posts
    3,424
    what kind of clearo's and coils ?

    Your not trying to run a nickel coil in Kanthal mode ?

  3. #3
    AVF Regular
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    1,830
    What clearomizers are you using?

    And what ohm coils as well?
    Hoofprint likes this.

  4. #4
    AVF Regular
    Join Date
    Jul 2015
    Location
    South West (WA)
    Posts
    1,015
    Mines fine, using it now with a nautilus @ 15watts in normal mode.

  5. #5
    AVF Regular
    Join Date
    Feb 2015
    Location
    Narre Warren North, Vic.
    Posts
    2,689
    More info on what your running is needed and what settings have you got on the eVic.
    Last cigarette, 11:00 AM 11th March 2015.

  6. #6
    AVF Regular
    Join Date
    Sep 2012
    Location
    Brisbane
    Posts
    477
    Why do I have the feeling that the 2.8watt setting OP proclaims is actually 28 Watts and he's running 1.8 oHm coils.......
    gtadmin likes this.
    Provari V2 - CF Sub-Ohm Battery - Eleaf iPower 80w - ECT X.FIR II - Aspire Nautilus - Aspire Atlantis - iClear 30 - Eleaf Lemo 2 - Alien RDA

  7. #7
    AVF Regular
    Join Date
    Dec 2013
    Location
    Marrickville NSW
    Posts
    2,949
    The coil can't turn red if it's soaked in juice.
    What clearomiser are you using, the one that came with the kit?

  8. #8
    AVF Newbie | Be nice to me
    Join Date
    Jan 2013
    Location
    Blacktown, NSW
    Posts
    37
    the clearos are bought from fasttech. not expensive ones. different types ranging $3-4

    i have been using them fine with my cloupor box. no issue at all.

  9. #9
    Super Moderator
    Join Date
    Jan 2012
    Location
    Whyalla, SA
    Posts
    13,095
    Quote Originally Posted by chris1972 View Post
    Why do I have the feeling that the 2.8watt setting OP proclaims is actually 28 Watts and he's running 1.8 oHm coils.......
    With no juice ...
    Ignore the Super-moderator tag in my profile, I have resigned from that position but admin have not updated my profile as yet

  10. #10
    Super Moderator
    Join Date
    Jan 2012
    Location
    Whyalla, SA
    Posts
    13,095
    You are sure it's 2.8W and not 28W? I have never seen a atomiser coil glow red hot when it has juice ... sounds to me like you are over-powering it like crazy ...
    Ignore the Super-moderator tag in my profile, I have resigned from that position but admin have not updated my profile as yet

 

 
Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 10:18 PM.