Page 1 of 2 12 LastLast
Results 1 to 10 of 17
Like Tree12Likes

Thread: First RBA build

  1. #1
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712

    First RBA build

    Delta 2 RBA - Ti 26g - organic cotton

    Is this normal? Looks very black.




    Sent from my iPhone using Tapatalk

  2. #2
    AVF Regular
    Join Date
    Jan 2012
    Location
    South Australia
    Posts
    17,417
    Looks cooked to me (no expert)
    addappt likes this.
    Colouring My World with Elegance
    Started Vaping 13th October, 2011

  3. #3
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712
    Lol that's after about 10 to 15 drags


    Sent from my iPhone using Tapatalk

  4. #4
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712

    First RBA build

    Should it taste burnt? Cos it doesn't


    Sent from my iPhone using Tapatalk

  5. #5
    AVF Regular
    Join Date
    Jan 2012
    Location
    South Australia
    Posts
    17,417
    Quote Originally Posted by addappt View Post
    Should it taste burnt? Cos it doesn't


    Sent from my iPhone using Tapatalk
    I use silica on all my rebuildables, I can dry burn to clean.
    addappt likes this.
    Colouring My World with Elegance
    Started Vaping 13th October, 2011

  6. #6
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712
    I have no idea what I'm doing mate lol


    Sent from my iPhone using Tapatalk

  7. #7
    AVF Regular
    Join Date
    Jan 2012
    Location
    South Australia
    Posts
    17,417
    Quote Originally Posted by addappt View Post
    Should it taste burnt? Cos it doesn't


    Sent from my iPhone using Tapatalk

    Again not sure of how you are vaping but that sometimes happens when you are firing too low and slowly boiling it to a caramel as opposed to vaporising properly. I am shooting in the dark because I don't know about your gear or coils.

    Handing the baton to other who actually know what they are talking about with this gear.
    addappt likes this.
    Colouring My World with Elegance
    Started Vaping 13th October, 2011

  8. #8
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712
    Thanks for the help mate.

    It's an EVIC VT on Ti mode. The coil is saying 0.3ohm
    As a comparison this is what the cotton out of the Stock Ti coil looked like after a week...



    Sent from my iPhone using Tapatalk

  9. #9
    AVF Regular
    Join Date
    Apr 2014
    Location
    Sunshine Coast
    Posts
    305
    Give us some further details .IE
    Wattage or volts being fired????
    Flavor of juice?????
    Ohms of coil?????

    Note some flavored Juice can turn wick brown quiet quickly, also did you prime the wick with drops of juice before firing ,and did you let the filled tank sit for a few minutes to fully saturate wick before vaping.
    The above is critical for someone to try and determine issue.
    Crisscross and addappt like this.

  10. #10
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712
    The mod is a EVIC VT TC mode at 260c with it set to 45 watts.
    Juice is strawberry flavour. No colouring.
    I think it's 50/50 pg vg
    Coil is reading at 0.30ohm

    It was wicked first and soaked for about 3-4 mins then pulled through without power 3-4 times.


    Sent from my iPhone using Tapatalk

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:48 PM.