Results 1 to 6 of 6
  1. #1
    AVF Regular
    Join Date
    Sep 2015
    Location
    Melbourne south
    Posts
    109

    EVic VT voltage surges

    Hey all

    I bought an evic vt to try sub ohm with temp control... Turns out this is not for me so I have just gone back to my old nautilus mini and kayfun setups which I love and up till now the evic has been great. I had the nautilus on and started to get a burnt taste thought I run it dry but has heaps of juice in it. Tried it again... Still burnt and really hot so I switched tanks .. Same again... Turned the unit off and on .. No burning but coil was now shot in the mini. On about 10W-14W I think these are surging to much higher watts randomly (will have proof soon if this is true have to get my multi back from a mate!).

    Anyone else had this problem at low watts on these units... I have 2 of them and now both seem to be doing this?

    Interesting tests done by pbusardo say much the same..
    http://www.tasteyourjuice.com/wordpress

    Would appreciate the feedback and hope to warn people about these units if your not using above 30W?? I don't know

    Thanks guys

  2. #2
    AVF Regular
    Join Date
    Feb 2015
    Location
    Narre Warren North, Vic.
    Posts
    2,689
    I don't run my eVic in wattage mode with kanthal, instead I use a ti build. Not the same of course but I have noticed something similar. When I use a new build and indicate to the eVic it is a new coil it really hits it hard. By this I mean it gives the coil heaps of power, I have to turn it down at first. After a few puffs I set it down and leave it for 30 minutes and when I pick it up again it is back to normal. I just think it takes a while to settle down and with a new coil it goes ballistic.
    Last cigarette, 11:00 AM 11th March 2015.

  3. #3
    AVF Regular
    Join Date
    Sep 2015
    Location
    Melbourne south
    Posts
    109
    Ah yes I have noticed this but this is apparently normal.. It supposed to surge when a new coil is attached as a way of testing the resistance of the coil.. Should only do it for less than a second though so it shouldn't be noticeable.. The problem I have is long after a new coil is fitted. Have noticed it more on first hit after it has been left for 30mins or so. You can hear it too... Does yours buzz and tick like a bomb all the time too.. Both of mine do this straight out of the box, I assume that's normal?

  4. #4
    AVF Regular
    Join Date
    Feb 2015
    Location
    Narre Warren North, Vic.
    Posts
    2,689
    The ticking is normal for every eVic.
    Last cigarette, 11:00 AM 11th March 2015.

  5. #5
    AVF Regular
    Join Date
    Sep 2015
    Location
    Melbourne south
    Posts
    109
    Yeah thought so... Cheers for the confirmation

  6. #6
    AVF Regular
    Join Date
    Aug 2015
    Location
    Adelaide
    Posts
    712
    It stops after 3 mins or something. 5 clicks and it's gone anyway.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 11:49 PM.