Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Like Tree1Likes

Thread: Aspire Triton Mini not wicking.

  1. #1
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131

    Aspire Triton Mini not wicking.

    Hi all,
    First post for me. Today I bought a Triton Mini and did all the things that I would normally; primed the coil and filled the tank and left it standing for at least 30 minutes. I thought that would do it. But I attached it to my hana modz and all it did was dry hit or barely make any vapor. I was severely disappointed by it as I seldom ever buy anything for myself.

    So I've now primed the other included coil and I'm letting it all sit.... I'm not even sure if it'll work if the other didn't.

    Any suggestions? I feel like the holes in the coil need to be far bigger!

  2. #2
    AVF Regular
    Join Date
    Dec 2015
    Location
    Sydney
    Posts
    231
    the only time i had a dry hit was when i forgot to open the AFC as I close it when not in use.
    also check the top cap is set to vape or probably test it with another mod.

  3. #3
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Got it all set right. I've had the AFC set nearly all the way off and open fully... and nada. The top cap is set right.

    I'll try another mod but a battery is a battery?!

  4. #4
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Ugh just had the damned thing leak a full tank of juice into the airflow chamber and out. So now disassembled and cleaned. I'll try again tomorrow.

  5. #5
    AVF Regular
    Join Date
    Dec 2015
    Location
    Sydney
    Posts
    231
    yeah the mod may not be at fault but a better isolation test is using the coil on another tank.
    My Nautilus had problems with claptons, it vaped like a cigarrette producing little vapour but that same coil worked fine on the Triton mini.

  6. #6
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Thanks, I'll try another mod.

  7. #7
    AVF Regular
    Join Date
    Apr 2013
    Location
    Toowoomba (West)
    Posts
    7,897
    What kind of juice are you using, 70/30 or all VG or.....?

    I don't have a triton mini so all I can come up with are the obvious things. Does the Triton mini have the juice controller on the fill/vape ring... ?
    Chris: Tobacco free since 17:00 15th March 2013.

  8. #8
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    I've got 50/50 vg/pg and it's pulling vapor but zero flavour no matter where I set the wattage... ugh. I feel like a dud...

    It does have the ring and it's set accordingly.

  9. #9
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    So apparently the tank creates a vacuum and it won't draw juice when it's fully tightened down. I've backed the tank from the base a little way and it draws a 'little' flavour into it... but shouldn't it just work?! (very little, but it produces clouds...)
    Last edited by gurishka; 03-04-16 at 11:15 AM.

  10. #10
    AVF Regular
    Join Date
    Dec 2015
    Location
    Sydney
    Posts
    231
    no issues with base fitting on mine. used it stick 40 W TC (its main mod), Cuboid. tubes like eGo One mini and a clone evod VV.
    The mini has no juice control other than the fill ports/slots on its top cap.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 09:43 AM.