Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Like Tree1Likes

Thread: Is my rx200 screwed?

  1. #1
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151

    Is my rx200 screwed?

    So. I've been using my rx200 daily since it came out. Recently it thinks it's charging even it isn't. The symbols etc come on and keeps the screen on. I updated the fw but still nothing. It gets really warm and obviously not usable cause it's draining the battery ironically by thinking it's charging. Is this it for my rx200?

  2. #2
    AVF Regular
    Join Date
    May 2015
    Location
    Bonnyrigg Heights, NSW
    Posts
    253
    perhaps theres something wrong with the usb connector. Maybe a pin is broken on a pin from your charger broke off in there. In any case I'd be contacting your vendor to try and get warranty claim done

  3. #3
    AVF Regular
    Join Date
    Mar 2013
    Location
    N.T.
    Posts
    2,255
    or you could charge the batteries in a standalone charger - the non DNA versions apparently have charging issues through the on board method

  4. #4
    AVF Regular
    Join Date
    Jul 2011
    Location
    Melb
    Posts
    5,139
    id pull it apart and cut the wires connecting to the USB charger and just use a real battery charger ( see if it still does it). You cant expect much from a 50 dollar china mod.
    You dont need USB charging with a triple 18650 mod.

  5. #5
    AVF Regular
    Join Date
    Feb 2015
    Location
    Narre Warren North, Vic.
    Posts
    2,689
    Quote Originally Posted by arth_d View Post
    id pull it apart and cut the wires connecting to the USB charger and just use a real battery charger ( see if it still does it). You cant expect much from a 50 dollar china mod.
    You dont need USB charging with a triple 18650 mod.
    But you do need the USB for firmware updates.

    I charge mine in a separate charger, always have. Don't trust the onboard charger to charge all batts evenly. With 7500mah in 3 batts I'm not going to wait that long to charge at 1000mah anyway.
    Last cigarette, 11:00 AM 11th March 2015.

  6. #6
    AVF Regular
    Join Date
    Jul 2011
    Location
    Melb
    Posts
    5,139
    If it works fine you dont have to update it.
    Quote Originally Posted by Cams View Post
    But you do need the USB for firmware updates.

    I charge mine in a separate charger, always have. Don't trust the onboard charger to charge all batts evenly. With 7500mah in 3 batts I'm not going to wait that long to charge at 1000mah anyway.

  7. #7
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151
    The USB charging has been proven to be usable. Reddit thread had someone test it out thoroughly. It stops charging any battery after one hits max 4.2 and it cuts off of If any battery goes under 3.6v. Charging isn't the issue though. The issue is the screen is always on now

  8. #8
    AVF Regular
    Join Date
    Apr 2013
    Location
    Toowoomba (West)
    Posts
    7,897
    Yep, sounds like it might be pooched. If it was mine, and if it's possible, I'd pull the PCB out and wash it with IPA, let it air dry, then reassemble. It might have some juice or other junk in there.

    Edit:
    Stuff that has a microprocessor and other chip devices on it can be very sensitive to transient currents floating around on the PCB and cause malfunctions. For example if some juice gets on the board it will attract other contaminants and may cause current to flow where it shouldn't be. Often washing the PCB down with IPA (or even metho if you can't get 98% IPA) can wash the contaminants away and restore the PCB to normal operation. As long as no permanent damage has been done to any semiconductors on the board it should be OK

    "Metho" is usually 95% ethyl alcohol and can be used. It tends to be a bit more harsh (than IPA) and more likely to damage varnish coatings and plastics.

    Most electronic cleaning sprays are IPA, but it's the most expensive way of doing it.
    Last edited by fabricator4; 13-04-16 at 09:10 PM. Reason: More explanation
    Fatman likes this.
    Chris: Tobacco free since 17:00 15th March 2013.

  9. #9
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Can you do a reset on the chipset?

  10. #10
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Ignore me. I've seen other mods a reset for the chip. Maybe contact wismec?

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 11:49 AM.