Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Like Tree3Likes

Thread: Eleaf 100W TC battery load

  1. #1
    R J
    R J is offline
    AVF Newbie | Be nice to me
    Join Date
    Feb 2016
    Location
    Lower Mitcham, SA
    Posts
    8

    Eleaf 100W TC battery load

    Hi,
    Can someone please advise? I have a new 100W Eleaf TC which can operate off single or dual battery. It appears to run off one only no matter if I swap batteries. I have 4 x brand new LG H2 3000mAH fully charged. I can put any battery into the second port & get no change to my power output display, which to me appears to only read the first cell (i.e. I get use from the 1st battery & then it goes flat after use). Is there something I need to do to activate the second battery port or is it faulty?

  2. #2
    AVF Regular
    Join Date
    Mar 2016
    Location
    Sydney
    Posts
    544
    If you're talking about the battery indicator, there is only one for both batteries.

    https://i.ytimg.com/vi/RMuWLYabegI/maxresdefault.jpg

  3. #3
    R J
    R J is offline
    AVF Newbie | Be nice to me
    Join Date
    Feb 2016
    Location
    Lower Mitcham, SA
    Posts
    8
    Thanks but it only registers half power at most, despite which way I swap batteries. Is that right?

  4. #4
    AVF Regular
    Join Date
    Jan 2015
    Location
    Griffith, NSW
    Posts
    3,424
    100w tc measures the 1st battery put in and uses that for the battery indicator.
    both sides drain at the same time if both batteries are installed, so eleaf didnt feel its needed for 2 drain indicators.

    if both your batteries are loaded into the mod Top side up,
    vape on it for a few hours then stick both batteries into a external charger (with a LCD display) or use a multimeter to check the voltage
    Mistic Lady likes this.

  5. #5
    R J
    R J is offline
    AVF Newbie | Be nice to me
    Join Date
    Feb 2016
    Location
    Lower Mitcham, SA
    Posts
    8
    Hmm & sorry, if I put 2 fully charged batteries into it then it should read full? Or does it display the first batt only (i.e. half) & then read the second. I have 2 fully charged new LG H2 batt's installed according to my charger. (Not multimeter)

  6. #6
    AVF Regular
    Join Date
    Jan 2015
    Location
    Griffith, NSW
    Posts
    3,424
    when you put 2 batteries in, the istick reads both, but the little battery symbol will only show the charge of one battery.

    As i said since they both drain at the same rate and the chip wont let you fire the device it with flat batteries, eleaf didn't see the need for 2 indicators

  7. #7
    AVF Regular
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    945
    Batteries are connected in parallel - I would have thought that the indicator shows the relative voltage of the combined circuit...

    Sent from my Nexus 7 using Tapatalk

  8. #8
    AVF Regular
    Join Date
    Jan 2015
    Location
    Griffith, NSW
    Posts
    3,424
    Quote Originally Posted by MelbVFR View Post
    Batteries are connected in parallel - I would have thought that the indicator shows the relative voltage of the combined circuit...

    Sent from my Nexus 7 using Tapatalk
    that's what i thought, but no i tested last night.
    I did the unthinkable and used two unmarried batteries. one at 100% the other at 10%.
    No matter what one goes in 1st the istick reads both then chooses the one with the biggest charge to display as the indicator.

    <WARNING- NOT TESTED>
    i haven't tested this cause i fell asleep on my keyboard again and i don't have a depleted battery.
    my theory is the chip will drain both regardless of charge levels and when the weaker one hits 0%.
    it will shut of that bay and only use the one with charge

  9. #9
    AVF Regular
    Join Date
    Jun 2014
    Location
    SW Victoria
    Posts
    3,808
    I think the OP keeps saying that all his batteries are fully charged and yet no matter what order he puts them in the meter is not reading full and he is worried he has a faulty unit.
    R J likes this.

  10. #10
    R J
    R J is offline
    AVF Newbie | Be nice to me
    Join Date
    Feb 2016
    Location
    Lower Mitcham, SA
    Posts
    8
    Yes that's correct merexy. No matter which way I put the batteries in I only get half charge displayed. So I have now tried to update firmware & the cable is charging the unit (will see if it eventually gets to full charge but currently still only showing half charge & charging) but the firmware upgrade will not run as it doesn't recognise the device at all.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 07:24 AM.