Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Like Tree4Likes

Thread: Herakles Help?

  1. #1
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97

    Herakles Help?

    Hey guys got a new tank today (SENSE Herakles) it reads on my k200 but not on my kbox 75? What could be the cause and or solution to this?

    TIA

  2. #2
    AVF Regular
    Join Date
    Feb 2015
    Posts
    5,140
    If its not showing any ohm reading at all....

    Probably the 510 pin at the bottom of the tank - may not be protruding enough to make contact with the 510 pin in the KBox 75 it looks like its adjustable - it has a flat blade screwdriver slot in the bottom, but id wait for a Herakles owner to confirm its adjustable...none of the sites i googled confirm this
    Stylemessiah: Prince of all things small and whispery. Abhorrer of shoutiness. Shunner of all vigorousities.

    Pushing back against the vendor wall, one damn stupid post at a time...

    Not on as many ignore lists as you think....

    Handy shopping links:
    Mods With Issues (Often On Discounted Flash Sale) Last Updated 13/10/17

  3. #3
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97
    thanks yeh it initially had a bit of trouble on the 200 but is reading fine now

  4. #4
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    What tank is it? A Herakles plus?

  5. #5
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97
    Quote Originally Posted by gurishka View Post
    What tank is it? A Herakles plus?
    just the reg herakles

  6. #6
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Got a pic mate? Sensetech make a lot of different tanks. I've got a Herakles Plus and Herakles hydra..

    The pin on the tank might be bottoming out on the kbox creating a short but this is the first I've heard of their tanks not reading on a mod. Sonetimes the o rings on the coils mean you have to screw them down fairly firm into the base. But if it's reading on the k200 I'd be checking the kbox 510 and giving it a clean and seeing if the pin is ok.
    Last edited by gurishka; 24-08-16 at 03:26 AM.

  7. #7
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97
    Quote Originally Posted by gurishka View Post
    Got a pic mate? Sensetech make a lot of different tanks. I've got a Herakles Plus and Herakles hydra..

    The pin on the tank might be bottoming out on the kbox creating a short but this is the first I've heard of their tanks not reading on a mod. Sonetimes the o rings on the coils mean you have to screw them down fairly firm into the base. But if it's reading on the k200 I'd be checking the kbox 510 and giving it a clean and seeing if the pin is ok.
    ah k how would i go about giving it a clean? ill just get on my phone and try to upload now for you cheers

  8. #8
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97



    Sent from my iPhone using Tapatalk

  9. #9
    AVF Regular
    Join Date
    Apr 2016
    Location
    Central Victoria
    Posts
    1,131
    Ah ha, that's the herakles sub ohm tank. :-)

    Grab some paper towel and make a tip and run it around the inside of the 510 connector. Check to see if there's anything loose between the pin and wall.

    Gently depress the pin too with something that won't marr it, like a wooden chopstick. See if the pin travel is ok.

    If you can, get some isopropyl alcohol swabs (the chemist might have some) and put the swab into the 510 and use the chopstick to move it about and clean it. You can use that same swab to try clean the 510 on the tank too.

    If you've done all that and the kbox won't fire with the tank then it looks like it's just one of those tanks that's selective on what mod it fires on.

    That being said, i thought the sub ohm needed pretty high wattage to get good results on, so you'd best be running it on the k200 anyway for battery life.

    Let me know how you go.

  10. #10
    AVF Newbie | Be nice to me
    Join Date
    Aug 2016
    Location
    Adelaide
    Posts
    97
    Thanks yeh we usually have alcohol swabs in the house - mums a nurse. But all I could find was iodine lol. I'll have to get some and try it. You're right the Herakles tank works better on the 200 it was rated at 30-100 but I've found smooth flavoursome hits even at 120! I'll just keep using it on the 200 for now... It just looked sick on my black 75 so wanted to try it. Cheers for the advice mate


    Sent from my iPhone using Tapatalk
    gurishka likes this.

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:22 PM.