Results 1 to 9 of 9
Like Tree2Likes
  • 1 Post By iamtezr
  • 1 Post By fabricator4

Thread: eVic doesn't charge...

  1. #1
    AVF Regular
    Join Date
    May 2017
    Location
    North East Victoria
    Posts
    517

    eVic doesn't charge...

    So here's the deal.

    I'm loathe to throw anything away if I spent money on it, so I decided to take the eVic apart to see if I can trace the fault (won't take a charge...).

    No signs of anything broken on the board... all soldering still seems to be intact.

    Any way to hotwire this mess and Frankenstein the science out of it?

    Sent from my HTC 2PST1 using Tapatalk

  2. #2
    AVF Regular
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    945
    Are you sure that the micro-usb connector is making contact ok ? Dirty contacts ? Cotton Bud & ISO - Have you got a multimeter to check if the inside of the connector is getting voltage when plugged in ?

  3. #3
    AVF Regular
    Join Date
    Aug 2016
    Location
    Melbourne, VIC
    Posts
    1,380
    Staceman,

    Does the mod power on when you plug it in via USB?
    If Yes and it's not charging then either 1,2 or 3 cells have gone bad in the lipo battery pack.

    You can either find the same lipo battery and replace it if you're confident in your soldering skills otherwise it's cheaper to replace than to repair.
    steve.c likes this.

  4. #4
    AVF Regular
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    945
    Good call - would be a quick indicator of USB connection status. . .

  5. #5
    AVF Regular
    Join Date
    May 2017
    Location
    North East Victoria
    Posts
    517
    Nah. Does nothing across multiple chargers, no charge going in...

    Sent from my HTC 2PST1 using Tapatalk

  6. #6
    AVF Regular
    Join Date
    Apr 2013
    Location
    Toowoomba (West)
    Posts
    7,897
    Quote Originally Posted by staceman101 View Post
    Nah. Does nothing across multiple chargers, no charge going in...

    Sent from my HTC 2PST1 using Tapatalk
    The mod will have a power regulator on the charge circuit, or some other type of charge regulation on the USB. Most likely that has failed. Static electricity can do that if there's no protection for spikes, or there might be a dry joint that you can't see considering it's double sided and you really need a microscope to inspect SMD boards properly these days.

    About all you can do is plug it in and verify that 5V is getting to all the places on the circuit board that it needs to. (multi meter, small probes, and detective work)
    staceman101 likes this.
    Chris: Tobacco free since 17:00 15th March 2013.

  7. #7
    AVF Regular
    Join Date
    May 2017
    Location
    North East Victoria
    Posts
    517
    Quote Originally Posted by fabricator4 View Post
    The mod will have a power regulator on the charge circuit, or some other type of charge regulation on the USB. Most likely that has failed. Static electricity can do that if there's no protection for spikes, or there might be a dry joint that you can't see considering it's double sided and you really need a microscope to inspect SMD boards properly these days.

    About all you can do is plug it in and verify that 5V is getting to all the places on the circuit board that it needs to. (multi meter, small probes, and detective work)
    Multimeter says no... so I'm guessing she's dead for whatever reason.

    Sent from my HTC 2PST1 using Tapatalk

  8. #8
    AVF Regular
    Join Date
    Apr 2013
    Location
    Toowoomba (West)
    Posts
    7,897
    Quote Originally Posted by staceman101 View Post
    Multimeter says no... so I'm guessing she's dead for whatever reason.

    Sent from my HTC 2PST1 using Tapatalk
    Zero volts at the USB where it connects to the board would just be a faulty USB or a dry joint. The plug should be 5V between pins 1 (+ive) and 5 (GND).
    Last edited by fabricator4; 18-10-17 at 01:13 PM.
    Chris: Tobacco free since 17:00 15th March 2013.

  9. #9
    emu
    emu is offline
    AVF Regular
    Join Date
    Nov 2016
    Posts
    3,024
    Shoulda got a Vaporesso

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 08:46 PM.