Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Like Tree6Likes

Thread: Dead Egrip

  1. #1
    AVF Regular
    Join Date
    Jun 2014
    Location
    Brisbane
    Posts
    1,382

    Dead Egrip

    Gday Simon, I'm just inquiring about my Egrip which now seems dead. You posted it to me on the 2/12/2014 so it is just out of the 90 day guarantee which is my bad luck I suppose. The first sign of a problem was about a week ago when it switched itself off from low battery power & when I plugged it in to charge no light came on but when I picked it up to see what was wrong the charging light started blinking & went out as I put it back down. I had to charge it with the USB lead hooked over something higher which must mean there's a problem with the USB connection. Now it is completely dead & can't be charged or used.
    I've always been careful plugging in the lead after I read about people posting about a weak USB to the board before I bought one. Are these things worth fixing?
    Regards
    Rod



  2. #2
    AVF Regular
    Join Date
    Dec 2012
    Location
    Quakers Hill NSW
    Posts
    3,733
    Yes One of mine is like that also, you have to fiddle around with it to make it work, I haven't taken it apart yet, been real busy but I will in the future once it gets worse. It is a real crap usb, Heavens gifts is the only place with a improved usb version that I've ever seen, Haven't ordered one yet. 20W Joyetech eGrip VW Kit - Limited Christmas Edition
    rodbam likes this.

  3. #3
    AVF Regular
    Join Date
    Aug 2014
    Location
    Campbelltown, NSW
    Posts
    398
    My mate Jackie had one of these that crapped out on her as well.
    She took it apart and from what she could see, basically the usb connection was only held on by 2 little solder joints

    She's thrown it all at me to see if I can fix it but from what I can see, the join was really really weak
    She got one of the early ones as well
    rodbam likes this.

  4. #4
    AVF Regular
    Join Date
    Apr 2014
    Location
    Melbourne, VIC
    Posts
    3,807
    Had the same problem with one of mine and my mates one. But others have been fine. Hit and miss really
    rodbam likes this.
    -Last Analogue-
    Thursday 24-04-2014 @ 4:00pm

  5. #5
    AVF Regular
    Join Date
    Jun 2014
    Location
    Brisbane
    Posts
    1,382
    Thanks mates there's nothing like not feeling alone:-) After I wrote my post above I tried again plugging it in & with my normal wiggle of the lead nothing happened so I tried a sideways wiggle as well & the bloody thing started charging. I have been vaping it but have put it on charge again before before the battery got too low & I would have trouble getting it going again. The Egrip is reminding me of an old 1949 Ford Prefect I had 50 or more years ago & if I didn't open the door a certain way & say 4 hail Mary's it would never start.
    Fatman, aussievapes and Noonoo like this.
    Regards
    Rod



  6. #6
    AVF Regular
    Join Date
    Jan 2015
    Location
    Geelong +15km
    Posts
    191
    same deal with mine it has snapped completely off inside though ! and a mates that wont turn on only sometimes with 30-40 pushes and some luck on the button.
    time for an exvostick as soon as they are released !

  7. #7
    AVF Regular
    Join Date
    Oct 2014
    Location
    Canberra
    Posts
    2,128
    Quote Originally Posted by slystu View Post
    time for an exvostick as soon as they are released !
    Ok I'll bite - what is an exvostick?

  8. #8
    AVF Regular
    Join Date
    Oct 2013
    Location
    Sydney
    Posts
    569
    It is a DNA40 that is being worked on by Chels who makes the Micro Stick.

  9. #9
    AVF Regular
    Join Date
    Apr 2014
    Location
    Melbourne, VIC
    Posts
    3,807
    They look the bomb, but my concern is with the dna chip having issues. Last thing I would want to do is have to send it back for repairs
    -Last Analogue-
    Thursday 24-04-2014 @ 4:00pm

  10. #10
    AVF Regular
    Join Date
    Jan 2015
    Location
    Geelong +15km
    Posts
    191
    As stated above !
    I need a work horse that can protect my tank while I'm at work and have electronics kato a don't have enough protection and the size of the Exvo is a nice size to cart around in my pocket!
    Wish the egrips were more reliable I would have stuck with them

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:02 AM.