Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    20

    Joye 510-T Auto Batteries

    I have recently bought a Joye 510-t starter kit from Health Cabin. Ive tried charging the 510-t batteries...but they dont seem to be charging.

    I screw them into the usb adapter and no lights go on...nothing. So i thought i would just leave the battery and the USB in my computer for a few hours and come back. When i take a puff it flashes 10 times....

    Infact the "specially made for 510-t" usb adapter doesn't seem to fit the battery well. For example, a regular manual 510 screws tightly into the adapter...the 2 autos don't.

    Am I doing something wrong?

  2. #2
    AussieVapers approved Vendor
    Join Date
    Sep 2010
    Location
    Fujian province, China
    Posts
    1,033
    Quote Originally Posted by McDoobies View Post
    I have recently bought a Joye 510-t starter kit from Health Cabin. Ive tried charging the 510-t batteries...but they dont seem to be charging.

    I screw them into the usb adapter and no lights go on...nothing. So i thought i would just leave the battery and the USB in my computer for a few hours and come back. When i take a puff it flashes 10 times....

    Infact the "specially made for 510-t" usb adapter doesn't seem to fit the battery well. For example, a regular manual 510 screws tightly into the adapter...the 2 autos don't.

    Am I doing something wrong?
    McDoobies,

    thank you for your asking.

    whether the batteries worked well before you charged them?

    whether the batteries were drained completely when you charged them with USB cable at computer? if they were, the USB adapter might be dead. please let us know your order number, we will send you a new free USB cable freely via china airmail.
    skype: newsunshine_2009
    www.healthcabin.net

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    20
    Hi,

    Thank you for the quick reply. Yes the autos worked fine, but they did not charge. I ordered a standard 810 manual battery from you as well and since the autos were not charging I decided to try and see if the manual would charge. It did charge from the USB adapter...the manual LED light flashed 3 times! I charged twice. First time everything was sweet, but the second time the 510 manual battery was very hot when charging, and when I pressed the button the battery did not work.
    The cover from the LED light has fallen off. I guess this was caused by the heat expanding the metal case. The button still works i think, because when i press the button while the manual is charging it flashes 4 or 5 times very rapidly, about half a second after I have released the button...I honestly don't know what the problem is. Maybe this information will give you a clearer picture of my situation.

    I believe my order number was #35222‏.

  4. #4
    AussieVapers approved Vendor
    Join Date
    Sep 2010
    Location
    Fujian province, China
    Posts
    1,033
    Quote Originally Posted by McDoobies View Post
    Hi,

    Thank you for the quick reply. Yes the autos worked fine, but they did not charge. I ordered a standard 810 manual battery from you as well and since the autos were not charging I decided to try and see if the manual would charge. It did charge from the USB adapter...the manual LED light flashed 3 times! I charged twice. First time everything was sweet, but the second time the 510 manual battery was very hot when charging, and when I pressed the button the battery did not work.
    The cover from the LED light has fallen off. I guess this was caused by the heat expanding the metal case. The button still works i think, because when i press the button while the manual is charging it flashes 4 or 5 times very rapidly, about half a second after I have released the button...I honestly don't know what the problem is. Maybe this information will give you a clearer picture of my situation.

    I believe my order number was #35222‏.
    Hi M,

    thank you for detailed explanation, which helps us a lot.

    1. as for 510 T batteries chaging problem, it is likely a problem with the 510 T cable. could you charge 510 T batteries with regular 510 USB charger or eGo USB charger? both regular 510 USB chargers and eGo USB chargers can charge 510 T batteries. when 510 T batteries are charged, the led will turn on. however, the led on 510 T batteries won't turn off forever, because 510 T batteries can not fully charged by regular 510 USB chargers and eGo USB chargers.

    if it is the case, please let us know. we will send you a new free good 510 T cable freely.

    2. as for the problem with 510 mega manual battery (you referred to 801, actually you ordered a 510 mega manual battery in the order ), i think, the battery is dead now. please send a warranty request to support@healthcabin.net.

    we will send a new free one to you freely too.

    any other questions please feel free to let me know here.
    skype: newsunshine_2009
    www.healthcabin.net

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 08:37 PM.