Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34
Like Tree12Likes

Thread: My RSST is starting to shit me.

  1. #1
    Senior Member
    Join Date
    May 2013
    Location
    Melbourne
    Posts
    1,721

    My RSST is starting to shit me.

    Never been too happy with my RSST, just doesn't perform well.

    Always though the hole was a little small so I just drilled it from 1.0 to 1.5 mm expecting greater results.

    Swapped form mech to ceramic with a 1.3 ohm coil now which I think is 32 AWG. Good wind.

    Has it on my Scud mech with a fresh battery and just swapped it to the ProVari with a fresh one too.

    Just **** all plume and taste.

    Have a nice fresh batch of Juice Whore Honey Wood Tobacco with 30V/70P at 18/100.

    All juices have been substandard to be honest.

    What's the issue? Any ideas?

  2. #2
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151
    its really hard to tell whats wrong without seeing it, poor performance could be down to many things. are you getting dry hits? is it making a good connection? is it wicking properly? etc. have a look at it firing, where in melbourne are you? if youre close by i could give you a hand.

    many attys have come and gone, but ill never sell my rsst. not a chance.
    studiovape likes this.

  3. #3
    Noe
    Noe is offline
    AV Approved Manafacturer/Modder Chief Snus scientist
    Join Date
    Jan 2011
    Location
    In the deep dark recesses of your mind! .. Prophet of the Vapeoligists & keeper of the sacred Bewdy.
    Posts
    13,140
    Hotspots maybe?
    It might not taste like a hotspot is there but it only takes a small one to drop vapor production & taste.

    Switching to ceramic it can take some extra time to break in too.
    Officially #1 Customer and Supporter of Essiemessy's Custom made Glass Drip Tips!
    Essie's Glass DTs

    Sent from my kickass gaming PC using keyboard & fingers.

    The Dahli Lama once said, "People do not laugh enough & take life too seriously, causing stress." A good laugh can cure a build up of stress, stress is a leading cause of grey hair & early death.

    Vape Hard or go home and Vape Hard!

    I'd rather be sneezing than wheezing!

  4. #4
    AVF Regular
    Join Date
    Mar 2013
    Location
    N.T.
    Posts
    2,255
    I find the rsst wicks too fast , but that is my wick being too loose I think. Are you using the butt plug? Ive already lost mine but wrapped some ss mesh in the fill hole. It helped a lot

  5. #5
    Senior Member
    Join Date
    May 2013
    Location
    Adelaide
    Posts
    611
    yeah i had a few issues with my RSST for a while but nothing major. then one day i wrapped a good coil got it firing really nice and omg it was flavour country. this is coming from a guy that has muted taste. the biggest game changer for me was when i started tweaking my coil when it was being fired makes it so much easier to get it working well. cant remember what you-tube clip it was i seen it on but big tip i got out of it was make sure the middle coils are firing first
    Juzm likes this.
    If that doesn't work try a bigger hammer!

  6. #6
    Senior Member
    Join Date
    May 2013
    Location
    Melbourne
    Posts
    1,721
    Quote Originally Posted by bronco View Post
    its really hard to tell whats wrong without seeing it, poor performance could be down to many things. are you getting dry hits? is it making a good connection? is it wicking properly? etc. have a look at it firing, where in melbourne are you? if youre close by i could give you a hand.

    many attys have come and gone, but ill never sell my rsst. not a chance.
    Getting hot hits a bit, it's wicking fine I think but the wick has only been in a day but it was sort of like this with mesh, maybe a little better. Connection is spot on. I'm in Fairfield/Kew area but have mod can travel. I'm on holidays this week but will be back at work in Southbank next week.

    Quote Originally Posted by Noe View Post
    Hotspots maybe?
    It might not taste like a hotspot is there but it only takes a small one to drop vapor production & taste.

    Switching to ceramic it can take some extra time to break in too.
    The coils are heating up very fast but that when I test it upright, hard to tell when I have it horizontal.

    Quote Originally Posted by lheamfrg View Post
    I find the rsst wicks too fast , but that is my wick being too loose I think. Are you using the butt plug? Ive already lost mine but wrapped some ss mesh in the fill hole. It helped a lot
    I pre-wound the wick tight and then counter screwed the wick in backwards so it was nice and tight but it isn't quite touching the wick in all spots, maybe that's it. I have the butt plug in but have tried it without as well. It's better in (the atty). If you still have your pack of spares you'll find a spare one in there.

    I like this jigger, I just want it to work properly. Seems to make a slight difference too when I swap from one drip tip to another.

  7. #7
    Senior Member
    Join Date
    May 2013
    Location
    Melbourne
    Posts
    1,721
    Quote Originally Posted by suspect View Post
    cant remember what you-tube clip it was i seen it on but big tip i got out of it was make sure the middle coils are firing first
    Yes, middle coils are certainly firing first.

    If I'm on a 1.3 ohm coil what would you guys be running this at voltage wise? 3.3 volts?

  8. #8
    Senior Member
    Join Date
    Mar 2013
    Location
    Baldivis , WA 6171
    Posts
    1,290
    I run 4 v on 1.3 ohm
    Juzm likes this.

  9. #9
    AVF Regular
    Join Date
    Dec 2012
    Location
    Melbourne Vic
    Posts
    3,151
    I'm in bundoora. I'll be done with work all week by 3pm.if u wanna swing past and I can give u a hand I'd be happy to help

  10. #10
    Senior Member
    Join Date
    May 2013
    Location
    Adelaide
    Posts
    611
    yeah i have a 0.9 ohm coil on mine atm and i find it best when batt is full charged in my mech so probably more then 4v at 1.3 ohms for me. depends how well its wicking i guess
    If that doesn't work try a bigger hammer!

 

 
Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 11:42 AM.