Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
Like Tree24Likes

Thread: How come...

  1. #1
    Senior Member
    Join Date
    Mar 2013
    Location
    Paradise City - AKA Melbourne
    Posts
    181

    How come...

    How come all the juices that taste reasonable on my ego twist, taste burney on my vamo at the same voltage? I can't even inhale because it just buuuuuuuuuurns! Am I missing something? Right now I'm thinking I've wasted my money on this stupid thing and should have just stuck to my twist.

  2. #2
    Senior Member
    Join Date
    Mar 2013
    Location
    Adelaide
    Posts
    306
    Switch it to Watts, then start low and keep bumping it up till its as good as (or should be better) than the twist.

    Then vape away into the sunset.
    shipo and MrGruffy like this.


    Quote Originally Posted by Nakor View Post
    Sod it, time to buy some chickens, pack the cat and move to an island.
    http://southanstreetorganics.wordpress.com/

  3. #3
    Senior Member
    Join Date
    Mar 2013
    Location
    Paradise City - AKA Melbourne
    Posts
    181
    I tried that, but no difference :/

  4. #4
    AVF Regular
    Join Date
    Dec 2012
    Location
    Off grid, quietly hermity, NW Tas
    Posts
    6,476
    Of the variables that could be involved here;

    Volts, you tried from low to high, lets discount that for now,
    Juice delivery system, assuming the same one from your twist to the Vamo, again, discount this for now
    Juice, as above
    Airflow. It could be that if you are using a device with an eGo threadm it may be screwed down into the top well of the Vamo and restricting your airflow, thus causing the burning taste as the juice is staying longer on a hotter coil. You'd notice this especially by a firmer/tighter draw. If this is the case, try the same combo with a 510 to ego adaptor or any other adaptor that raises the bottom of your eGo clearo above and out of the Vamo well.
    Vamo DOA and falsely reporting low volts and actually delivering high volts. Unlikely.

    Post of pic of your setup with detail on the attachment of the juice delivery device to Vamo connection point?
    GirlyPantz, shipo and margyb like this.


  5. #5
    Senior Member
    Join Date
    Mar 2013
    Location
    Queensland
    Posts
    1,160
    Is your Vamo in RMS mode? If it is in mean mode (N01) you can experience what you describe. Do you know how to check it?

  6. #6
    AVF Regular
    Join Date
    Mar 2012
    Location
    Sydney (vaping since Nov 2011)
    Posts
    2,144
    as long as they don't taste stabby you're ok.

  7. #7
    Senior Member
    Join Date
    Mar 2013
    Location
    Adelaide
    Posts
    306
    Didnt think about it being screwed down too tight in the well..

    And heres the instruction manual,

    http://www.e-cigarette-forum.com/for...user_guide.pdf
    margyb likes this.


    Quote Originally Posted by Nakor View Post
    Sod it, time to buy some chickens, pack the cat and move to an island.
    http://southanstreetorganics.wordpress.com/

  8. #8
    Senior Member
    Join Date
    Mar 2013
    Location
    Paradise City - AKA Melbourne
    Posts
    181
    Quote Originally Posted by MrGruffy View Post
    Airflow. It could be that if you are using a device with an eGo threadm it may be screwed down into the top well of the Vamo and restricting your airflow, thus causing the burning taste as the juice is staying longer on a hotter coil. You'd notice this especially by a firmer/tighter draw. If this is the case, try the same combo with a 510 to ego adaptor or any other adaptor that raises the bottom of your eGo clearo above and out of the Vamo well.
    Hmmm... It's possible that it could be the fact that I'm using a CE4 and it was screwed in too tightly. I say that because when I went to unscrew it, the whole bottom came off (juice EVERYWHERE). I put it back on the twist with what juice was left and it was still vile. Could I have stuffed the clearo in the process? Having said that, I just tried a mt bcc (fit loosely onto the thread, and with a different flavour), and this one is actually OK. The draw is still really hot and burns the back of my throat like nobodies business, but I can at least taste some flavour. Also tried a mini vivi with a juice that I only received today, and that was burney on both the vamo and the twist...

    I don't have a 510 adaptor, so I can't try that.

  9. #9
    Super Moderator
    Join Date
    Jan 2012
    Location
    Whyalla, SA
    Posts
    13,095
    Quote Originally Posted by second_chance View Post
    Is your Vamo in RMS mode? If it is in mean mode (N01) you can experience what you describe. Do you know how to check it?
    Sounds like this could be the problem to me ...
    Ignore the Super-moderator tag in my profile, I have resigned from that position but admin have not updated my profile as yet

  10. #10
    Senior Member
    Join Date
    Mar 2013
    Location
    Paradise City - AKA Melbourne
    Posts
    181
    Quote Originally Posted by second_chance View Post
    Is your Vamo in RMS mode? If it is in mean mode (N01) you can experience what you describe. Do you know how to check it?
    Ooooh... No... I didn't get that far in the instruction manual. I was a bit too excited haha. I'll have a look in a min

 

 
Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 07:38 PM.