Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Like Tree1Likes

Thread: Ego twist problems

  1. #1
    Senior Member
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    261

    Ego twist problems

    I seem to be having trouble with one of two ego twists i have . When I screw it into the recharger nothing happens , normally I would lay the blame on the recharger as it seems a bit flimsy , but the other twist I have recharges normally . Does anyone have any tips or suggestions as to what may be the trouble. I have ordered another 2 chargers just in case the one I have is to blame , but they won't arrive for a couple of days . Any and all help much appreciated.

    just remembered , sometimes it works if I unscrew it , give it a jiggle and screw it back on , but its got worse and worse and now I can't get it to work at all.

  2. #2
    Member
    Join Date
    Dec 2012
    Location
    Brisbane
    Posts
    77
    Could be a few things.

    First off, give the contact on the battery a good clean with a tissue or similar. I've had a buildup of juice-gunk give me issues with firing before. If that fails, have a good look at both battery contacts, does one seem higher than the other? Also check the battery threads, if one is slightly off it may be causing the trouble.

    Did the battery which isn't charging ever have any issues with atomiser connection?

  3. #3
    Senior Member
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    261
    Both batteries were working perfectly using iclear 16s . Now the one that won't charge is flat , I'll try cleaning the connection but I'm pretty sure no juice has leaked/dripped down on it.

  4. #4
    Senior Member
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    261
    Ok , I managed to get it charging . I cleaned it with a cotton bud , a fair bit of black gunk came off , tried charging it , not working , then I got a small pair of nail scissors , and gently tried to lever up the connection , not sure if I did anything , but screwed it on and now charging . I'll wait till the new chargers arrive , but if it is a twist problem , will I be able to get a replacement ? it's only 6 weeks old.

  5. #5
    AVF Regular
    Join Date
    Mar 2013
    Location
    Bunbury, WA
    Posts
    5,951
    it sounds like the firing pin (probably the wrong name. the bit inside the top of the battery that makes contact with the charger and atty) in the twist has kind of sunk in a bit. you might try getting some needle nose pliers and try very gently easing it out a tiny bit.

  6. #6
    AVF Regular
    Join Date
    Mar 2013
    Location
    Bunbury, WA
    Posts
    5,951
    oops. you found that solution. we musta posted at the same time. where did you get it from?

  7. #7
    Senior Member
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    261
    I got it from vapebar . I've ordered a bit of stuff from them , that's where the 2 new chargers are coming from . Pretty happy with the service , but if turns out it is a battery fault I'll probably drop them a line .

  8. #8
    AVF Regular
    Join Date
    Mar 2013
    Location
    Bunbury, WA
    Posts
    5,951
    no harm in emailing them and letting them know you have an issue. they might even have a fix you can do to resolve it.

  9. #9
    Senior Member
    Join Date
    May 2013
    Location
    Townsville
    Posts
    374
    The trouble is 510 connections on all clearos vary wildly in length.
    Where you may have to screw one all the way down to make a connection another might make contact well before it is all the way on.
    A good practice to get into is just to screw your preferred clearo down until you feel resistance. Then hold it to your ear to see if it is firing. If it is just leave it where it is. Otherwise if you just screw everything down all the way you will just push the centre pin on your battery down.
    Well at least Vaping has stopped my god awful wheezing

  10. #10
    Senior Member
    Join Date
    Jun 2013
    Location
    Brisbane
    Posts
    261
    Ah , thanks mate . I'll do that from now on , as you have guessed I'm screwing the thing down till its finger tight.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 06:27 PM.