Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Like Tree12Likes

Thread: Evod cartomizers stop working!

  1. #1
    AVF Regular
    Join Date
    Aug 2013
    Location
    Melbourne
    Posts
    179

    Evod cartomizers stop working!

    Hey guys,

    I have a really annoying issue. I bought 2 Kanger Evod BCCs last week, and 10 replacement coils. They worked great for a week, now they are not firing at all. I get no vapour or anything.

    I've tried replacing the coils (didn't help), screwing the post on tight, but they are dead. They died yesterday, but started working again, and now have died again.

    I know it's not my batteries, because my other clearomizer is working fine on them all.

    Does anyone know why my 2 evods are doing this or how to get them firing again?

    Cheers.

  2. #2
    Junior Member
    Join Date
    Jul 2013
    Location
    Strathmore, Vic
    Posts
    25
    occasionaly have the same issue.
    Sounds like they are not contacting the battery.

    I usually give the coil/head a squeeze from underneath (where it screws onto the battery)
    with a pair of needle nose pliers. keep trying till they work.

    thinking of using/trying some aluminium foil (cut by a hole punch) to put on top of the inner battery post.

  3. #3
    AVF Regular
    Join Date
    Apr 2013
    Location
    Melbourne
    Posts
    1,549
    DO NOT DO THAT.

    You will likely cause a hard short which could fry your device, or worse seriously damage your battery.


    The first thing to do is check is to see if your positive pin on your device has been pushed down too far. If so you can carefully lift it back up using a small screwdriver/pin/paperclip. Search Youtube if you need a tutorial.

    Each clearo will have slightly different length positive pins (the 510 standard is hardly a proper standard). That means that some types may work, while others may not. If mixing between brands/types you may have accidentally pushed your positive pin on the device down to a point where it works with one, but not the other. A pretty common issue.
    Noe, GirlyPantz, TheDishD and 3 others like this.
    ಠ_ಠ

  4. #4
    AVF Regular
    Join Date
    Oct 2011
    Location
    Hobart Tasmania
    Posts
    5,658
    I only have 1 evod, but used to have similar problems occassionally with my stardusts.
    Try pulling the metal tube down a bit. The tube in the base of the evod that sits on your battery. Gently with some needle nose pliers or tweezers.
    Might help :=)
    TheDishD likes this.

  5. #5
    Super Moderator
    Join Date
    Jun 2011
    Location
    The Wild West
    Posts
    2,261
    I tried these for a little while without much success. Always seemed to stop working or taste like primer for ages... yuck.

    margy's suggestion is sound though, give that a try

  6. #6
    AVF Regular
    Join Date
    Aug 2013
    Location
    Melbourne
    Posts
    179
    Thanks a lot. I tried all the things, pulling out the positive pin, etc. No dice. Then I just changed the coils completely, and they are working. But I changed the coil once before and the same thing happened.

    Could I be screwing the carto onto the battery too tightly? Can I stuff it up that way?

  7. #7
    Super Moderator
    Join Date
    Jun 2011
    Location
    The Wild West
    Posts
    2,261
    Quote Originally Posted by Shpondra View Post
    Thanks a lot. I tried all the things, pulling out the positive pin, etc. No dice. Then I just changed the coils completely, and they are working. But I changed the coil once before and the same thing happened.

    Could I be screwing the carto onto the battery too tightly? Can I stuff it up that way?
    Doesn't need to be super tight, I would refrain from that

  8. #8
    AVF Regular
    Join Date
    Aug 2013
    Location
    Melbourne
    Posts
    179
    Thanks, I'll loosen a bit. Aah the joys of being a noobcake.

  9. #9
    Noe
    Noe is offline
    AV Approved Manafacturer/Modder Chief Snus scientist
    Join Date
    Jan 2011
    Location
    In the deep dark recesses of your mind! .. Prophet of the Vapeoligists & keeper of the sacred Bewdy.
    Posts
    13,140
    From what I am hearing about Kanger bottom coil devices, they all are not as good as a VOBCC or a CE3(VK XL comet). Protanks seem to be awesome to start with then get progressively worse, T3's were just a hit & miss affair, some were great others were terrible(no not clones), Evods seem to be slightly better but still not as consistently good as a VOBCC or a CE3.

    CE3's are IMO still the king of bottom coil devices, a VOBCC is a very small step behind in vape quality but has a larger tank capacity, Kanger bottom coils seem to me(having never tried them) to be devices that work well sometimes & terrible at others.
    I know there are Kanger BCC users that will swear by them & have a different opinion to my own & I can only judge them by all the reports of problems other vapers have with them, however I see far fewer bad reports about VOBCCs & rarely any about CE3's.
    TheDishD likes this.
    Officially #1 Customer and Supporter of Essiemessy's Custom made Glass Drip Tips!
    Essie's Glass DTs

    Sent from my kickass gaming PC using keyboard & fingers.

    The Dahli Lama once said, "People do not laugh enough & take life too seriously, causing stress." A good laugh can cure a build up of stress, stress is a leading cause of grey hair & early death.

    Vape Hard or go home and Vape Hard!

    I'd rather be sneezing than wheezing!

  10. #10
    AVF Regular
    Join Date
    Feb 2013
    Location
    Melbourne
    Posts
    692
    Quote Originally Posted by Shpondra View Post
    Thanks a lot. I tried all the things, pulling out the positive pin, etc. No dice. Then I just changed the coils completely, and they are working. But I changed the coil once before and the same thing happened.

    Could I be screwing the carto onto the battery too tightly? Can I stuff it up that way?

    Yep, don't screw them down too tight.

    Sometimes loosening them a bit actually fixes the problem.

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 01:41 PM.