Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By Juzm
  • 2 Post By kevinkc

Thread: Hippo cap issue

  1. #1
    Member
    Join Date
    Nov 2013
    Location
    Glenroy, VIC
    Posts
    76

    Hippo cap issue

    wondering if anyone with a provari with hippo cap has ever had any issues? got my vape mail today and tried to fire her up, no go. tried an i clear30s and protank 2. went to check the ohms and got an "OP" on the screen. is it possible i got a dud?


    Sent from my iPad using Tapatalk

  2. #2
    AVF Regular
    Join Date
    Oct 2013
    Location
    Melbourne
    Posts
    3,690
    got a multi meter?

    also check positive post is making conact w pos post on atty




    Gaffer Tape is like The Force - it has a light side, a dark side, and it holds the universe together

    Without specific approval, No one has permission to quote me outside of AVF

  3. #3
    Member
    Join Date
    Nov 2013
    Location
    Glenroy, VIC
    Posts
    76
    no on multi meter, i have a feeling the hippo contact isnt touching the provari contact thingamajig. dont want to overtighten as i may strip a thread


    Sent from my iPad using Tapatalk

  4. #4
    AVF Regular
    Join Date
    Oct 2013
    Location
    Melbourne
    Posts
    3,690
    can you adjust the positive post on the hippo ?




    Gaffer Tape is like The Force - it has a light side, a dark side, and it holds the universe together

    Without specific approval, No one has permission to quote me outside of AVF

  5. #5
    Senior Member
    Join Date
    Sep 2013
    Posts
    701
    The post inside the Hippo is adjustable so give that a go.
    Photo on 3-01-2014 at 5.20 pm.jpg

  6. #6
    Senior Member
    Join Date
    May 2013
    Location
    Melbourne
    Posts
    1,721
    Quote Originally Posted by Altered1 View Post
    can you adjust the positive post on the hippo ?
    Yes, hold the centre part with your thumb (510 female) and forefinger (510 male) and spin the body, the outer is threaded on the inner.

    Failing that, if it's tight, turn it over and use long nosed pliers or a flathead screwdriver to hold the centre (there is a special cutout, don't touch the thread) and spin the outer.
    Pipesub likes this.

  7. #7
    Member
    Join Date
    Nov 2013
    Location
    Glenroy, VIC
    Posts
    76
    YES! worked like a charm! thanks so much!


    Sent from my iPad using Tapatalk
    Olfella and Pipesub like this.

  8. #8
    Senior Member
    Join Date
    Dec 2012
    Location
    Mount Gambier SA
    Posts
    1,228
    I have an issue with my Hippo V2 if anyone cares to lend some advice ?

    I bought it to use pretty much for aesthetic purposes between a Provari Mini and the EhPro KFL - the hippo threads perfectly fine onto ANY other device I have, except for the KFL........ goes on about 2MM turn and then stops dead, I am afraid it a force it, I will ruin them both. I have tried working it back and forth and tried lubing up the threads,.... no luck. Every thing else I try device wise threads on seamlessly, as does the KFL to any device I own also.

    Any advice as to overcoming this issue ?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 01:19 AM.