Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Like Tree10Likes

Thread: New ELEAF iStick Pico/Melo-3 Mini Kit Thick burning smoke

  1. #1
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11

    New ELEAF iStick Pico/Melo-3 Mini Kit Thick burning smoke

    Hey guys! Brand new to vaping, Just purchased the Eleaf istick pico with the melo-3 tank and a whole bunch of flavours, Took it out the box , put a suitable battery in.
    Did not touch any settings all I did was power it up , Fill it up with some Bubblegum flavour and set it to 30W. So it still has the 0.3 ohm coil in it (30-80W)
    Did about 5-10 runs without inhaling just to let it run in a little, and it's blowing out thick burning smoke (not the eliquid) A couple more after that the tank is getting slightly warm and starting to also spew a little bit of hot burning thick grey smoke slowly out of the bottom of the tank near the air slots

    Any ideas whats happening? I've just put it down and put it on charge so I dont risk doing any damage. My brother has the exact same one and his is perfect on 40W! I think his friend may have set his one up for him though.

  2. #2
    AVF Regular
    Join Date
    Nov 2016
    Location
    Western Australia
    Posts
    247
    Was the coil primed with juice? Could have been the cotton dry burning.
    2/12/2016

  3. #3
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11
    What does that mean sorry? I've let it fire for 10 seconds at a time, for about 10 times and it just kept producing that awful burning smell and thick burning grey smoke

  4. #4
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11
    I filled the tank about 1/2 up the glass aswell if that's any help, I've just left it sitting beside me on the desk charging in fear I might damage it or something haha

  5. #5
    AVF Regular
    Join Date
    Nov 2016
    Location
    Western Australia
    Posts
    247
    When you use a new coil it will take a few minutes for the juice to soak through the cotton. Some people will prime it by giving it a squirt of juice on the coil itself before screwing it in, I let mine sit for ten to fifteen minutes.

    If there is no juice in the actual cotton itself it will just burn the cotton in the coil and produce the burning taste. It may still be ok but you may need to change the coil out.

    https://m.youtube.com/watch?v=RdS1LjCIep4 this may help you understand
    2/12/2016

  6. #6
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11
    Ok so i primed the coil, Thanks for the vid, Left it for 5-10 mins, It's still spitting out thick grey smelly nose destroying burning smoke even on just 30W. And I ran it about 15 times, and It looks like it may be spitting out very tiny bits of hot eliquid to.

  7. #7
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11
    I've taken the tank off and cleaned it extensively with warm water and dried it , I'll try prime the coil again shortly maybe it didnt soak in long enough

  8. #8
    AVF Regular
    Join Date
    Feb 2017
    Location
    SA
    Posts
    257
    Firstly, welcome to AVF, secondly, can you go to your profile and edit/put in, your location - there maybe someone nearby who can help. Thirdly, I wouldn't be charging anything that's emitting smoke, it's NOT a sign that things are going well, if the battery's the issue, things may get nasty. I'm not familiar with your gear, hopefully someone who is, will pop along soon to help

    Quote Originally Posted by J91V View Post
    Ok so i primed the coil, Thanks for the vid, Left it for 5-10 mins, It's still spitting out thick grey smelly nose destroying burning smoke even on just 30W. And I ran it about 15 times, and It looks like it may be spitting out very tiny bits of hot eliquid to.

  9. #9
    Super Moderator
    Join Date
    Oct 2011
    Location
    Qld
    Posts
    4,976
    Start on lower watts and work your way up.
    Ingrid

    Quote Originally Posted by rockmoose View Post
    Is Ingrid the only one who thinks my penis looks slightly vaginal?

  10. #10
    AVF Newbie | Be nice to me
    Join Date
    May 2017
    Location
    Perth, W.A
    Posts
    11
    Have taken off charge , I started on 1W then 5 - 10- 15 - 20 - 30 and it kept doing same thing, Thick smelly burning grey smoke, Any other ideas?

    Gave the tank a sick clean and re-primed it letting it sit for 20 and see if it works
    Last edited by J91V; 01-05-17 at 08:58 PM.
    FXVaper likes this.

 

 
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 08:03 AM.