Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By flyingfox12

Thread: My E-Juice Steeper Ultrasonic

  1. #1
    AVF Regular
    Join Date
    Dec 2016
    Location
    Anywhere I hang my coat up
    Posts
    577

    My E-Juice Steeper Ultrasonic

    Moderators, I do not know if this is on topic for this board, but I feel I should warn people about this unit. I read a bit about Ultrasonic E-Juice steeping and decided to give it a go.
    Ok I go on Fleabay searching. The first one I purchased nearly set fire to my residence. The report is below.

    This is the first UltraSonic Cleaner I bought for steeping E-Juice, DANGER DO NOT BUY THIS UNIT





    It is the 600ml job with no heaters and a 3 minute cycle. It was too small for me and I gave it to the wife to clean her jewelry and I used it to clean my Sako Watch. It worked well for about 6-7 times for that task and then shet itself. During this time while it was still working I ordered the 2L cleaner with the heater from the same fleabay supplier and to this day it works great.



    The plastic one pictured above believe me folks, it was a piece of rubbish and down right dangerous. When it ceased working on the 8th attempt I had lengthy correspondence (About 5-6) emails video and pictures which I had to send to the supplier. global living (Ebay) eventually after much haggling, (how unusual with the Chinese) I received a full refund on PayPal. They did not want it back. Ok, so I dismantle it and I damn near had a heart attack. Water got into the circuitry, how you tell me, it is supposed to be a totally sealed unit. Did the Ultrasonic generator unseal it?



    Several components were black where the short circuit occured, one componet got so hot that its solder melted and it separated from the circuit board and it was dangling on the 240V cord. . Yes, it did have a 1amp fuse on the circuit board which btw was soldered in and not replaceable (Stupid Idea) The fuse was intact and did not blow. Why? Is that not what a fuse it for?



    I am fortunate that this unit did not melt and set fire to my residence although, when I do use the UC I do it in the laundry on a metal surface away from any flammable material. The other factor that saved me from a fire disaster was that my household fuse in the fuse box blew when this happened. My household fuses were of a better and more protective quality that the inbuilt fuse on this UC. All the components were sent to my Electrical Authority with the same report as I write here. No doubt this supplier and manufacturer will be getting a very nasty letter from our Electrical Appliance Accreditation Authority.



    When you buy in Australia an electrical appliance from a B&M shop it has to be certified safe to Australian and New Zealand Safety Standards, which by the way are very strict, when you buy on Fleabay or Amazon you take pot luck. My Big UC cleaner the 2L one I took to an electrician and had it checked out. It passed. (Cost me $45AUD extra to have it inspected, then again, how much is your life and that of your family worth)
    fabricator4 likes this.

  2. #2
    AVF Regular
    Join Date
    Mar 2011
    Location
    Brisbane
    Posts
    1,409
    Thats what happened to mine-also from fleabay.
    it was only 20 bucks or so as I remember, quite small, but it worked 3 times and then just stopped,- the bottom had a big dimple corresponding to where it had short circuited.
    I was lucky the thing didnt catch fire and burn the house down,

  3. #3
    AVF Regular
    Join Date
    Apr 2013
    Location
    Toowoomba (West)
    Posts
    7,897
    I'm guessing the top of the water container is not sealed against plastic case. Condensation running down the side from the lid or overfilling would appear to guarantee a failure. (I note there is water on the surrounds of the lid closure in the image but this might have occurred after failure).

    It might be possible to not over fill the container initially, but when you put large things like 30ml bottles into the bath (or your fingers getting something out) could push the water level over the safe point.

    Dreadful design if that is the case.

    Come to think of it, even tipping the water out is probably an issue.
    Chris: Tobacco free since 17:00 15th March 2013.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 10:23 PM.