Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By nikolous

Thread: WTB sigelei fuchai 213

  1. #1
    AVF Regular
    Join Date
    Oct 2013
    Location
    Geelong
    Posts
    489

    WTB sigelei fuchai 213

    Dont like my luck here but just seeing if anyone has a fuchai they are looking to move on before i grab a new one online. Not too fazed on what colour.

    Sent from my SM-T710 using Tapatalk

  2. #2
    AVF Regular
    Join Date
    Jul 2015
    Location
    South West (WA)
    Posts
    1,015
    Are you after the Sigelei 213W OR the Fuchai 213W ?

    Sigelei retails for $129 and up the Fuchai goes for $79.95 and up.

  3. #3
    AVF Regular
    Join Date
    Oct 2013
    Location
    Geelong
    Posts
    489
    Probably just the fuchai mate, aren't they pretty much the same thing apart from one has a carbon fibre panel?

    Sent from my GT-I9505 using Tapatalk

  4. #4
    AVF Regular
    Join Date
    May 2015
    Location
    Bonnyrigg Heights, NSW
    Posts
    253
    Fuchai is the new "fixed" one
    Andyj likes this.
    Current Mods
    • Triade DNA200
    • Therion DNA75
    • Broadside
    • Noisy Cricket V2
    • Punto Zero
    • Kimech
    • USV-L

    Current Attys
    • Monster V3
    • Squape X
    • Kayfun V5
    • Reload RTA
    • Goon
    • Goon v1.5
    • In'sane
    • Hadaly
    • Tricktank Pro
    • Tokugawa
    • CSMNT
    • BMI Nova
    • Icon
    • Pulse 22
    • Narda
    • Flave 24
    • HAKU!!!

  5. #5
    AVF Regular
    Join Date
    Oct 2013
    Location
    Geelong
    Posts
    489
    Anyone know where i can get a blue fuchai within Australia? Been searching but only coming across the black and the gun metal.

    Sent from my SM-T710 using Tapatalk

  6. #6
    AVF Regular
    Join Date
    Mar 2016
    Location
    Sydney
    Posts
    544
    The steamery has blue in stock.

    Your funeral though. I suggest you read the reviews before forking out $90 on it.

  7. #7
    AVF Regular
    Join Date
    Oct 2013
    Location
    Geelong
    Posts
    489
    From what ive read, the problems seem to be in temp mode, which i dont use so i think it will work fine for me....... hopefully haha.

    Sent from my SM-T710 using Tapatalk

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.4
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0
All times are GMT +11. The time now is 03:03 PM.